Revoicing – possible bug?

I inadvertently wrote a bit of music in a down-stem voice, then reassigned it via the Voices > Change Voice > Up-stem Voice 1 function… and everything got shifted by a quaver! :frowning:

Bug? –π

Don’t deselect the clef before you start the operation.

Daniel, actually I had tried without deselecting the clef first and got the same result!

The only way to work around it seems to be to add a note to that first rest, revoice, then delete the note. And this behavior only seems to happen on the viola staff—maybe something to do with the clefs?

I can’t reproduce this in a new project, even reproducing the same music exactly, so as usual I suspect that I would need to see the project to be able to diagnose the problem.

Daniel check the 8M1abc project file I shared with you in the private message, bar 59 in the violas.

I also just noticed something funny: when I click bar 59 then repeatedly hit CMD+SHIFT+RIGHT ARROW to select more bars, it gets stuck after selecting bar 72…

Actually, it seems to always get stuck after selecting a whole-note bar!