Rewire crashes Cubase5 studio +

I have a number of rewire programs Kenetic, Reason 6, Reaper. They all show up in the devices menu, but when I try to load them Cubase hangs. It starts loading the mixer and it just stays there with the blue bar moving back and forth while every thing else is frozen. I cant close it, or access anything. I end up having to do a hard reboot.
I’ve used reason with Cuebase many times in the past but all of a sudden it seems Cubase wont connect with any rewire devices. I’ve tried them all and its always the same problem. Tried different order of loading:
open Cubase>open Reason>Select rewire device and open Cubase>select rewire device>open Reason. No difference. And since I’m on this board, does anyone know how to get Halion one presets back? I gave up awhile ago. I point the brower to the content and nothing, media bay nothing. I can see the content, cant load it… No idea why THAT stopped working either…
Last, songs I’ve completed and saved are coming up as corrupted when I reopen them months later??
Any help appreciated. I’ve been with Cubase since SX3 and don’t want to have to switch to something else, but its stuff like this thats kept me from going to C6.
I’m running all 32 bit BTW.

This issue is solved either by trashing Prefs or replacing the rewire.dll file in the Cubase Program folder, IIRC.

Thanks for the quick response, that got me back my rewire immediately.
I found that if I open Halion One from Device>VST Instruments>Halion One it does not see any of the presets.
If I open it as a right click>Add Instrument Track and assign Halion One then its sees the track presets from the Inspector panel only. Does that make sense. It works so I can live it.
Thanks again!

Try right clicking on the H1 GUI that has issues and choose Locate Contents, pointing to C:\Program Files\Steinberg\Cubase 4\VST3 Presets\Steinberg Media Technologies\HALionOne.

My rewire wont show up in cuebase 8.5 win 10 64bit can u help Please