Rhythm dot consolidation is not working as expected

Activating the Rhythm dot consolidation in the Properties is not working here. What might be the reason?

grafik

You’d need to explain your Engraving Options, I think. Uploading a project would be better.

What do you expect Dorico to do here, Juerg? Do you want Dorico to move the lower of the two dots rightwards to align with the dot that is avoiding the flag, or something else?

Either way would be fine. If the dot happens to collide with the flag I could move the flag upwards a little.

The rhythm dot consolidation option (or property) doesn’t apply in this situation, I’m afraid, since Dorico is able to display both of the rhythm dots anyway. The consolidation option applies in situations where showing all the rhythm dots would cause a large amount of horizontal space to be added. In this case, because the notes are a third apart, the option has no effect.

I’ve often thought that it would be helpful to have a similar property for the Rhythm dots for notes on flags engraving option, so you could override that choice on a case-by-case basis, but we don’t have that capability at the moment.

You might find the Lengthen stem option in Engraving Options an acceptable compromise for this project.

Thanks for the explanation, Daniel. It really is just a small thing. The Lengthen stem option does the job.

Aufnahme5