Ride cymbal won't playback

I’ve been working on an arrangement for a jazz combo and everything was working normally until yesterday when I was almost done with the drum part the ride cymbal stopped playing back. Everything else in the drum kit still works, and the ride cymbal plays when I click on individual notes, but not in playback. I’ve tried changing the percussion and expression maps (between default and GM percussion maps and between default and CC11 Dynamics expression maps), to no avail. I don’t fully understand how to edit percussion maps so I haven’t tried that yet but everything worked before and I didn’t change anything in percussion maps. I’ve attached my dorico file if you want to take a look. Any ideas? Thanks.
ridecymbalplaybackerror.zip (913 KB)

I’ve been looking at this, and despite trying quite hard to figure it out, I’ve not been able to. However, the good news is that if you add a new drum set player to your project and copy and paste the music from the old player to the new player, the ride cymbal then plays back correctly. You could then remove the old drum set player.