right hand fingering (guitar) issue

In the attached project, see bars 34-35. Add a fingering notation “t” under the first note of each bar. Watch what happens with the right hand fingering m notations and the slur above bar 34. On my system it moves up away from the staff by a noticeable distance. Delete the t’s under the staff and the above-staff notations return to normal. This happened one way or another throughout the region that I tried.

Also, it would be nice if I had space between a r.h. fingering notation and the top line of the staff, where I could place a slur. I have flattened the slurs in this project as much as I dare in order to accommodate notations above the staff. I can live with it as it is, but not with fingerings jumping up and down. Should I have made this a separate topic? I’d be glad to do that if you don’t mind my constantly posting things.
Prelude.dorico.zip (989 KB)

Ok I think it has to do with these settings. (screenshot) I’ll ponder them. I’ll be grateful for any further enlightenment. It’s working ok now. I think.

I made a screen video of what Dorico is doing with my guitar fingerings, but I haven’t been able to get it small enough to attach to a post. The problem is real and disruptive. If it would be helpful I would gladly to do whatever I must to make the video available to you. The project is attached to an earlier post.

Full disclosure: Half of my 20-year career in embedded systems software engineering was designing and running automated tests on barcode scanners. I understand if you don’t rejoice when you see my posts coming. I think your software is elegant and robust. It has never crashed on my watch. Unlike the days of old, I won’t be quietly gleeful if it does, because you are not paying me by the bug. Our target was a bug a day. I don’t see coming anywhere near that with Dorico, and that’s great news.

That looks like an unexpected behavior. But the good news is that if you go to engrave mode and select the fingering that coincides with the beginning of the slur (“m” in bars 34 and 35) you can set the Slur-relative position to “Outside” and that will correct the position of the slurs (maybe you want to reset the slurs engraving options then?). The not-so-good-news is that you have to set the property one by one (or is it just that i am unable to find the correct setting?)