RME Asio spikes are still there after .10

A lot of windows processes are not multithreaded, and are running on the first CPU core. If you look at the task manager you will notice the first core has a lot more to do than the rest. That’s why Studio One has the ability to set core affinity in the preferences, something I would like to be able to do in Cubase. I think it is worth a try, it helped my older system a great deal when I got problems with spikes.

My studio PC has 8 cores, the first is hardly ever the most loaded one once Cubase is up and running.

For all my OSs since Vista, I have just relied upon Windows Update, which tends to focus on providing stable and bare-bones versions, to install the correct stuff for the motherboard.

The ‘official’ latest packs from Gigabyte and ASUS, at least, have many utilities and services that optimise for their purpose or their primary audience, gamers, but hog more resources than really required, so creating problems for multi-streaming.

The core parking fix helped me a lot with the ASIO spikes.

http://forum.cakewalk.com/Windows-7-amp-Core-Parking-a-better-way-to-Turn-It-OFF-m1861804.aspx

“On a windows computer, what happens if you, open the task manager. Go to the Cubase task, right click and on affinity choose to disable Cpu 0 ?”

The affinity trick cause Cubase crash (Pro 8.0.10)

Win 7 64 SP1

The most significant post in that thread is the one that shows how to expose the Processor performance core parking min cores option within the Processor power management section of the Power Options/Advanced settings dialog, making the setting changeable on the fly without rebooting.

To enable the option in W8.x (probably same in W7):

  1. Open the Registry Editor
    __ by typing regedit in the Start screen, and pressing the Enter key.

  2. Open the Find dialog
    __ by pressing the Ctrl+F keys.

  3. Search for the 0cc5b647-c1df-4637-891a-dec35c318583 key
    __ by typing it into the Find what field, and pressing the Find Next key.
    __ The key contents are displayed, usually showing 0x00000001 (1) for the Attributes value.

  4. Change Attributes to 0
    __ by double-clicking on Attributes, typing 0 into the Value data field, then clicking the OK button.

  5. Close the Registry Editor
    __ by the usual culprits.


    To change the core parking % in W8.x (similar in W7):

  6. Open the Power Options dialog
    __ by clicking the Power Options link in Control Panel.

  7. Open the Advanced setting panel
    __ by clicking on any Change plan settings link, then the Change advanced power settings link on the resulting page.

  8. Show the option
    __ by selecting the High performance option (the one you should be using!), then expand the Processor power management section, then expand the Processor performance core parking min cores subsection.

  9. Specify the setting
    __ by clicking the Setting field, then typing the required % (0 = no parking, 100 = all can be parked).

  10. Save the setting
    __ by clicking the Apply button, or the OK button to also close the dialog at the same time.


    However, before embarking on all this, as some point out in that thread, trying to force use of more cores may lead to processes jumping core, with attendant performance loss due to having to transfer process state. Basically, Cubase and samplers should be managing core use, not users.

“making the setting changeable on the fly without rebooting.”
Nop if you don’t do a full reboot it doesn’t work in Win 7.
In my case the core was still parking until I shut off and do a full restart.

I use an HDSPe MadiFX and HDSPe-AES in the same PC. No CPU spikes at all in v8.10.

Ok
In my case the problem seems to be fixed.
I used to have drop outs,spikes and audible noises on recording and was condemned to use 512 or above buffer settings.
After parking cores (i5) still have occasional drops spikes and still have to work with high RME buffers but replacing latest Nvidia drivers (3.41.44) with 320.49 finally did the trick.
Now I’m in 64 buffer with absolutely no ASIO spikes nor audio drop outs and zero noises.

My system was so solid that I even enabled the turbo option in my bios and despite my i5 is 2.9 it’s running now at 3.5
No EIST,C or speedstep enabled.
ASIO guard on at normal settings.

Everybody having problems with ASIO spikes should check video card drivers particularly NVidia.

Cheers

HDSP 9636 also clic spike and ASIO usage riddicoulus, around 20% with 2 plug in the control room and one audio track with no plugs!!! I’ve an i7 at 3,5 gh, 16 g ram and win 7 64 bit. I can’t believe the C8 work worst than C6.5 :cry: :cry: :cry: :cry:
PLEASE Steiny solve this!!!

it doesnt sound like a steiny issue. the versions act differently but i think your solution is all in the bios. try there instead of waiting.

I bypassed my RME now completely and use the O1V96i mixer > Yamaha Steinberg USB AUDIO driver.

No more spikes whatsoever running huge projects at 256 and as low as 128 with ASIO Guard ON.

Cause I only use 1 AD/DA converter in the chain my sound also improved @ 96kHZ.

So it is a RME issue and not Cubase one. Well at least in my situation

Good luck to everyone. RME will hopefully fix this soon.

Hi Mbr,
Well that is a quick deduction. But if I read this thread oldest to newest I find some RME folks are having the issue and others are not. I also find mention of other interface brands including Steinies that have problems as well. So I do not think it is solely an RME issue. Rather it seems to be a combination issue of certain interfaces & systems along with Cubase. Also I don’t think this was present in this degree in older versions of Cubase.

I know one thing, all this talk about the fun folks are having with RME, other Interfaces and Cubase are preventing me from buying Cubase 8 and that is a shame.

LB

I am very Happy o see another cubase user solved but I tend to agree this is leap, but for a different reason.

I can run a whole stack of VST outside of Cubase on the same hardware with the same ASIO videos drivers (it is the same OS) without any spikes or odd behaviour or reduced performance. Yet the same instruments just played from a midi keyboard in cubase will not reach the same performance mark because of the spike overhead.

I realise there should be some overhead given all the other things Cubase does but really this is quite a dramatic difference. What is odd is it is only the bursty spike, not the normal Load that kills it. The normal load appears to be comparable.

I am still hunting for a system monitoring tool that can actually tell you want occurs at the moment of the spike. So far everything says ‘cubase8.exe’.

Need more diagnostic tools - anyone at steiny, what you use? Is there a debug mode I can log and then look and see what is happening in the realtime path?

Hi Robw,

What you shared is interesting! I notice you also have a Steiny interface!

Not sure what exactly one would use but could not Perf Mon in Windows do some tracking of this issue possibly? I realize you would rather have some sort of detailed report output when the issue happens. Someone on here must be a developer and have debugging tools that could be used to try and analyze this issue?

I also see the spikes as the main issue as the average meter in Cubase seems to be almost reasonable.

Sure hope this is solved soon.

LB

Hi Lbro44

I’m a software developer of old, still cutting code on occasion. No audio stuff though, unfortunately so the debugging tools I have aren’t cutting it for this. Perf mon, sysmon, Afterburner GPU logging server, latencymon, DPC checker and a few others aren’t showing much.

My suspicion is the spike on the Cubase realtime meter is for a very very short time period and the only reason it appears to higher on average is because it takes a while for the realtime meter to fall back down (you can only eye ball this because you can’t log this meter to a file, change its time average window or anything useful like that). Being so short all the performance monitors are logging at to large a time period to isolate the spike. The other thing it the music side of my PC runs pretty lean, almost no other services. Cubase8.exe is the only thing showing up anywhere.

I’d quite happily run diagnostics tools from Steiny on this to help the problem. To many of us Cubase owners, with two many different systems are showing very similar problems - and every single one of us is really guessing as to what the problem is due to a lack of decent diagnostic tools. I’ve no issue buying specific hardware for the purposes of running Cubase, but it’s quite another thing to randomly try things, sometimes buy things.

We need some decent Cubase diagnostic tools. All of us.

I risk hijacking a thread here, since I don’t own an RME device. Just wanted to share the thought but I am very happy for mbr’s victory dance on being able to use Cubase as intended. I was there once, will probably be there again. Just wish it could be made less random for everyone.

Hi guys, spike are disappear in my case simply disable Audio Core CPU in BIOS, and audio on HDMI. Disable all audio setting under the ‘video’ section of the BIOS have solved my spikes but the ASIO performance remain worst tha C6.5 and this is not normal!!!

I found the pulsating audio and distortion problems i had with a new RME UFX ii on USB 2.0 were graphics related. After an update with recent minimal, no acceleration etc active, ATI Radeon drivers on Windows 10 64bit they seemed to be gone. With Cubase 9 latency is set to only 64 samples, ASIO guard on BTW. Before that i’ve been messing with various windows and BIOS settings to do with USB. That wasn’t the problem after all … - F