RME Babyface, Cubase 6 and Audio of Digital Piano


I have got the following system and connections:

Intel cuad laptop on Windows 7 64bit with Realtek onboard soundcard connected to RME Babyface via USB

Kawai ES 6 digital piano connected to RME via Midi (both Midi in and Midi Out)

Kawai ES 6 Audio Out to RME AN 3/4

RME AN 1/2 to stereo

Cubase 6 Elements with Toontrack’s EZ Drummer as VST.

Latency of 2.2 ms according to Cubase.

Now, I can us the Toontrack EZ Drummer inside Cubase perfectly, playing the Midi groove patterns and listen to it etc.

However, my Kawai’s piano sound seems delayed, distorted, play additional notes, does not sound like the original onboard Kawai sound etc. . I am pretty sure that I am have messed something up in Cubase or RME but have not clue how to salvage it from here. I can record Midi perfectly but the piano sound I listen to while playing is a mess which does not makes seens to me because I thought the original sound would go through the audio cable as I play it in when direct monitoring is enabled, so I should have no lag and my indeed the Kawai piano sound. Weirdly enough I do not see a yellow bar in the RME mixer in any channel when playing on my piano even though I have connected the piano’s Audio out to the break out cable Analog 3/4. However, when playing the Toontracks VST AN 1/2 is moving as it should.

Perhaps someone here can help me this as it is all very confusiing to me.

Do I also need to connect the piano via its USB port to my laptop (the piano’s USB only transfers MIDI though)?

How to connect/ set up my system (RME, Cubase) such that I can listen to the onboard piano sound while still recording the information as MIDI? And when I later want to export the whole project will I have to change something to make sure that say Midi track 1 is played back with the Kawai piano, Midi track 2 via the Toontrack VST and Midi track 3 by another VST (for example to emulate a bass)

I would very much appreciate your help

Kind regards


Hello Frank ,

I am not familiar with the RME , but it seems to me that the Analogue 3/4 inputs may just need setting up in VST Connections and/or the RME Connections ( or equivalent , however they call it ).
How are they routed now ?

Make sure Local is set to Off on the keyboard. Also, In Device Setup-MIDI Config. Make sure only the ports for the MIDI interface are selected to show and only select those as the input of the MIDI track.