Rosetta and Cubase 12 - Omnisphere not found

Hello I’ve just made the switch to an M2 max processor from intel. When running cubase in Rosetta mode everything is working fine. When it’s in Apple Silicon mode, it complains that it cannot find Omnisphere in the warnings when I open a project which was created on my intel macbook. But then once the project is open I am able to initialise a new instance of Omnisphere. Omnisphere is also clearly visible in the list of VST instruments. It’s a problem because if I reselect Omnisphere on any channel for which it can’t find it, it will reinitialise the patch, so my work will be lost.

Any suggestions of how to fix it? Other than running in Rosetta mode!

Hopefully the images will make it clear what I’m on about…

Thanks!




Hi,

Didn’t you use older version of Omnisphere in the given project? Or VST2 plug-in version?

Hey Martin. I don’t think so. But how could I confirm that, if I open the same project on the intel laptop? What would I click on to confirm?
Thanks!

Hi,

I have just realized, you might be right. If Cubase recognize the very same plug-in in VST2 and VST3 format, it hides the VST2 version. If I’m not mistaken, this has been introduced in Cubase 11 (or 12). So you would need to enable the VST2 version manually after.

What I would try to open the projet on the Intel Mac and double-check, if there is Omnispehere VST2 available at all. You would find this in the Instrument list, or in the Plug-in Information window.

OK. I’ll check that later on thanks for the suggestion!
Does it say Omnisphere VST2 somewhere? I’ve never seen mention of VST2 or 3, so not sure where to look.

But I don’t think it would explain why it works if I open cubase in rosetta mode. It’s cubase 12.

Hi,

In the VST Plug-in Manager there is the VST Version column.

1 Like

You were right. I can see the versions used in my project without opening on the intel mac. And yes, 7 instances of Omnisphere version 2, not 3. How silly of me. And annoying. I had no idea, but I must have made a mistake somewhere in last setup of Omnisphere, or something like that.
I assume VST2 doesn’t work in Apple silicon mode?
To allow myself to run in Silicon mode I guess I need to save my Omnisphere patches which are running as VST2. Then I can hopefully reopen them using VST3…?
Thanks for the quick response!
Screenshot 2023-06-08 at 18.18.18

Hi,

Right, it doesn’t.