Rosetta only bug?

I have been trying to resolve an issue here at the forum. No one has been able to help.
I tried YouTube and as expected there was my solution.

It didn’t work for me.

This issue is only happening in Rosetta mode.
Is it only me?


Could you link the post, please?

At the top of the first post

There seemed to be a bug with the file dialogs in Mac OS with cubase 12.

I had hoped it would be solved by moving up to Ventura 13.5 as that’s what folks were saying; That it was a bug in the OS level components that Cubase and other apps use when popping up file save dialogs.

However I still see FREEZES up to 40 seconds when opening save dialogs when Cubase is running in Rosetta.

If you wait long enough you may get a useful dialog and may be able to save.

Can you define “freezes”?
I can exit the dialogue, so not technically freezing.
If this a Mac OS issue I would expect to see a lot more posts here about this.

The behaviour I have seen on Mac OS 11, 12, 13:

  • File save or file open dialog action causes a long pause, sometimes with a spinny color wheel (beach ball) icon.
  • Duration of UI non-responsive freeze 10-30 seconds.
  • After that point, keyboard works and you can type a name for your file or click in the file dialog to open or save files.

To be clear I think the problem is in the Mac os itself, not in cubase as the same freeze affects file dialogs in Reaper, and in Apple apps like pages.

It may be caused by a slow or non responsive network folder mapped into the current user’s filesystem.