Route 1 midi track to 8 instrument tracks. Is it possible?

I want to route one single midi track to 8 instances of the Dexed DX7 plugin to stack 8 sounds and emulate a TX816. I am aware of the method using midi sends, but that means you can only route the same midi to 4 instrument tracks. I need a method that allows me to route to more. I was previously a Mixcraft user, and there was a great feature that allowed you to route a single midi track to essentially an unlimited number of instrument tracks. How can I route a single midi track to 8 instrument tracks?

I don’t want to copy and paste the midi to 8 tracks, I want to be able to play all 8 plugins from the same midi track so I can have the amazing realtime feeling of the TX816 sounds, but without needing to quantize and match 8 midi clips, or without deleting the 7 copies, fixing the first, and copying it back to the other 7. SURELY a program as advanced as Cubase 10 will let you route one midi track to as many instruments as you want?

Many thanks.

Or you could use the MIDI Sends to route to 4 more MIDI (not Instrument) Tracks and then use the Sends on those to route the MIDI to up to 16 Instrument Tracks. Only kinda ugly…

Hi,

Unfortunately, there is no other way but using MIDI Sends (in general).

This doesn’t work, I can only get the midi sends on my midi tracks to route to instruments. The other midi tracks don’t show up in the list at all. It’s like my midi tracks are all invisible to each other.

I just checked and you are right the MIDI Tracks aren’t available as destinations. I’m fairly sure (well sorta) that I’ve done that in the past…?

You could get a Virtual MIDI cable like LoopBe which both MIDI & Instrument Tracks can see and use it to feed all your instances. I’ve used LoopBe since forever likely there are other worthy contenders worth a google search.

How I’d do it:

I’m on a PC, so I need a virtual MIDI port. I personally like the free loopMIDI (can dynamically create/remove ports at will, and name them anything you like). Macs have virtual port capabilities built into the OS.

Set the output of the MIDI track to a virtual port. Set the input(s) of your instrument tracks to the virtual port, or ALL when you need to also get your controller information into an instrument track. Enable the monitor of the instrument tracks so the MIDI input can pass through and trigger sounds at the instrument track(s) endpoint(s).

Also, one can use empty MIDI tracks to serve as a ‘MIDI router’ during the technique of looping MIDI back into Cubase via virtual port. Such tracks can include Logic inserts to ‘filter/echo/transform’ events in real time.

Maybe this is what you are looking for: Unify by PluginGuru. Reasonably priced and so far I have found it to be very stable and it does a host of other things you might be interested in.

LoopMDI certainly did the trick for playing, but mixing down it doesn’t work, all the tracks go silent. I guess the workaround is to copy the midi to the actual tracks once I’m done writing? Still really annoying that there isn’t an easier process.

Can you post some pics of how you have it configed.

Sure thing.

loopMIDI setup


the master midi track (ignore the missing input, my keyboard was unplugged when I took these). Note the loopMDI port is set as the output.

one of 8 instrument tracks all configured the same, with the loopMIDI port as the input.

In order to hear the 8 instrument tracks while playing the master midi track, I have to enable monitoring on all 8 tracks. The issue is that when mixing down, for some reason the master midi track is not sending midi to any of the 8 plugins. The midi track itself knows there is midi, because the indicator is active, but all the tracks go silent.

Here’s the track setup while playing

and during a realtime bounce, to illustrate it’s definitely not getting through.

Normally when you route 1 midi track to 1 instrument track right inside Cubase, the midi track is sending to a specific target and the instrument track doesn’t need to specify anything. I’m guessing the issue is that with this setup, the instrument tracks need to actively listen for the midi input, and I’m not sure how to make that happen.

That looks like it is all setup correctly. Try sticking a MIDI Monitor as a MIDI Insert on your TX Track and a couple of the Dexed Tracks & see if that offers any clues.

About not copying Midi parts. Are you aware of shared copies?
https://steinberg.help/cubase_ai_le_elements/v9/en/cubase_nuendo/topics/parts_events/parts_creating_shared_copies_c.html

I use it across multiple instrument tracks to e.g. stack basses and other synths a lot. I edit on one track and all will follow automatically. No need to delete and copy again.

1 Like

I just made a little test project & am getting the same results. But after poking around I found a LoopBe setting that mutes monitoring on it. Deselect that and it works as expected.

image

image

The other alternative would be to record enable all the Tracks while Playing and then each Track would have it’s own Part instead of having to copy them between Tracks.

Route the instrument tracks into a bus track of the type you want (stereo, quad, ss, whatever). Make a new audio track(s) and set the input(s) as the group you made. Activate record on the new audio track(s)’ play the project and bounce down in real time. In short, you may need to mix in real time…instant rendering might not work well in such cases. Basically, you want to treat this portion of your project as if it were external synths instead of VSTi plugins. Am on the road so I cannot put up examples and tests, but there might also be export options to force real time exports. If not…just bounce down manually and export the mixed down tracks you need.