Routing a recorded Midi track


I’ve recorded A Midi track from my synth (easy peasy).
I’d like to route that Midi track to VST Instruments.
I could copy and paste the Midi to different Instruments but I would prefer to route the Midi track to multiples since editing would only be in one place.

I trued using Midi Echo in the Midi send of the Midi track and selecting Absynth as the Instrument -
but Absynth indicates it’s not getting any midi events.

Can someone help me, please.

Are you wanting to route it to the VST as an extra route or as the only route?

If the only route then you just need to change the destination in the track inspector.

If you’re wanting to send the MIDI track to the VSTi as a second target then the MIDI send is indeed the way to go. Not sure why you’ve added the MIDI Echo though, you just need to to select the send target (your VSTi). Make the sure the MIDI send is enabled. Other than that can’t think of any likely problems…it should just work.

You might want to explore Shared Copies which let you have multiple copies of the exact same Part. So if you edit one of the copies all of them will change.

With the Select Tool (arrow) alt+drag the Part you want to copy (so far this is exactly the same as making a regular copy). After you can see the new copy but before you drop the Part add the shift key so it is shift+alt+drag and then drop the new copy. Now you should see an “=” on both Parts indicating they are Shared Copies. Once a Part is set as Shared you can copy & duplicate as normal and it will stay Shared.

Edit/Functions/Convert to Real Copy - turns off sharing for a Part.

Thanks guys. This is a great forum.

I love the idea of shared copies so I can edit one instance of a part.
But I can see uses for the routing solution too.

I just need to figure out why the routing solution isn’t working for me.
I think I’ll try re-doing the entire part when I get home. I must have screwed up somewhere in the process.

At this point some screen grabs showing how you’ve got stuff setup might be useful.

I did not know this :open_mouth:

If retrying a midi recording and simple routing doesn’t work, I will definitely post some screen grabs.
I have 3 more hours at work before I can get to that.

Well, sort a bit of success. I created a new midi track and copy/pasted notes in it and set the Midi send to go to Absynth.
It words but my track-part shows diagonal lines (see picture). Any idea why that may be?

The original TEST 1 still doesn’t work although the midi send setting looks exactly the same.
TEST 2 works fine but with diagonal lines.

BTW, it took me 5 tries to get this picture posted.
Forum kept saying max pixel width is 700 but it appears to have a 600 pixel limit.

I figured out the diagonal lines… overlapping lanes.

Well, Solo is On in the picture.

Yes Solo is on as intended. If both are unmuted, I would appear that both tracks were sending to the Absynth channel.
I only took one screen grab - I gave up doing a second after multiple uploads.

Anyway it’s working now. I obviously screwed something up the first time.
The only thing that I did that may have been weird was that I recorded the first track in a lane of a sampler.
I tried to drag the lane up to a Midi track and that didn’t work so I did an alt-drag and that worked.
The I removed the sampler which appeared to remove the sampler recording but not the midi track recording.
I then used a midi send from that Midi track.
In redoing for TEST 2, I didn’t drag the part but copied the notes into the Midi Track.

Next time I’ll just record directly into the Midi track that has it’s send going to an Instrument.