Ruler mode: Bars/beats or Time not saved with project

This seems illogical to me: Why does the Ruler display not get saved with the project? Instead, Cubase always keeps the last used mode.

This means if I switch between music projects and, say, editing projects for which I want a time display, I’m forever changing this setting back and forth.

If there’s a pref to control this I can’t find it.

Main ruler is like that.

Add own ruler tracks with various timebase to have it available is what I do.
And a track divider line to keep the stuff always visible(up on the right in project window).
Then to minimize thinking differently - I set default track time base time linear - then knowing new tracks added are of certain timebase.
There is a setting to follow main ruler or not for timebase, I mean. Which will vary if to reset timebase on new audio or midi tracks - whatever you prefer.

This is what I do to keep minimum effects on different projects.

But tricky part is that primary and secondary time in transport bar lives it’s own life.
Thinking to make macro and key command for that to set main ruler and these settings so they follow.

Saving different workspaces are also helpful to recall as needed. And they can be global or project specific.

There is also a setting “Open Projects in Last Used View” on Preferences General tab to decide to follow project or not.

I use the following workaround on Windows 10 and Cubase 8. Should work on Mac.

  1. Find “Default Project Workspace.xml” file in your Cubase Application Data Folder.
  2. Open File in text editor and delete all data. Save and close.
  3. Change file attributes to “Read Only”. This prevents Cubase from writing to this file.
  4. Change the Preferences setting in Cubase for “Open Project in Last Used View” to “Always”.

With this method, my projects open with the zoom and ruler settings I last saved the project with. There is only a slight pause when opening projects while Cubase tries to access the “Default Project Workspace.xml” file.