running C6 as administrator (solves closing lag )?

for the last couple of months ive been having the problem of c6 lagging and it was due to the automap software from novation causing the problem and when i spoke to novation they got me to reinstall the lastest supported version of automap and then run as aministrator and then open c6 running as administrator which solved the problem but one thing he would not do explain was why it would make a difference ??
So here is the fix if anyone else is having this issue but im also asking if anyone out there would know the reason wh it would make a difference ?/
thanks
john

From Wikipedia (on UAC):

"Applications written with the assumption that the user will be running with administrator privileges experienced problems in earlier versions of Windows when run from limited user accounts, often because they attempted to write to machine-wide or system directories (such as Program Files) or registry keys (notably HKLM).[4] UAC attempts to alleviate this using File and Registry Virtualization, which redirects writes (and subsequent reads) to a per-user location within the user’s profile. For example, if an application attempts to write to “C:\program files\appname\settings.ini” and the user doesn’t have permissions to write to that directory, the write will get redirected to “C:\Users\username\AppData\Local\VirtualStore\Program Files\appname\settings.ini”.

Perhaps Cubase and Automap assume that the user is running the software as administrator or have UAC disabled. When this isn’t the case, File and Registry Virtualization kicks in, causing overhead in terms of processing and in turn causing the issues you described?

brilliant ,cheers for that james , you learn something new every day ive never thought of running any program as administor before .

much appreciated

john

Aloha f and thanks for this thread. And mahalo to J for the research.

Even on a Mac parts or this info might be very useful to some Cubase users.

{’-’}

hello curteye

just for the info for others ive found out how to “run as administrator” permanently if not installed correctly

1 right click the cubase icon
2 select the compatibility tab
3 either tick the "run as administrator " box at the bottom for using cubase with a named user or click on the "run as administrator " box and then tick the “run as administrator” box for any user
4 press apply and press ok twice and it’s all done .

this is should in most cases cure the lag of cubase closing down when your using the latest supported automap from novation …

i hope this helps someone !


john