running Cubase 4 Essential /w newer license on older Machine

will Cubase elements usb elicenser work to auth/run a copy of Cubase 4 Essential?

(Jan 2008)
https://www.steinberg.net/en/company/press/archive/2008/steinberg_cubase_essential_4.html

(Feb 2008)
https://www.steinberg.net/en/newsandevents/news/newsdetail/article/cubase-essential-4-is-now-shipping-326.html?tx_ttnews[pointer]=96&cHash=02f3a0b9048b5069b20e0aa8714cbacf

(Oct 2008)
https://www.steinberg.net/en/newsandevents/news/newsdetail/article/cubase-essential-45-update-available-422.html?tx_ttnews[pointer]=65&cHash=5080ba648707c97a1f9027a2bc21132c

im only asking because im trying to make use of an old 2008 imac with an intel processor + 6GB RAM

ive tested it with elements 6; but not with essential 5 or essential 4;
(because of the name being different?)
please let me know if u have any experience to share