I have read many discussions on this forum about a particular problem: Trying to record a track and adding an effect realtime. It seems everyone is getting the same problem I have. There is a horrendous delay in the time the monitor gets the signal processed back with the effect.

My vst connections are set up the right way. Mix Control seems to be set up the right way. I have read numerous steps watch a crap load of videos on youtube, but none fix this problem. I cannot for the life of me record a vocal track with the monitor button on without getting a delay for the processed signal. I would find it incredible I would need to switch my audio interface. I did not have a problem with cubase 6. It seems upgrading to 7 has done this.

So, if anyone can assist with this problem specifically for Saffire Pro 40, Mix Control version 3.2, Cubase 7, Mac OsX 10.8.3. If would be a great help, since my work has stalled due to this problem.

Have a look at your pro 40 buffer size settings,

Adjust them smaller find a size that works well with your system make your recording them put it back to 1024 until you need to track something else’s.

Hey there,

When recording with Focusrite units, you’ll need to mute the track in Cubase and raise the input’s fader in MixControl (the appropriate mix’s tab being selected) for zero latency monitoring while you record. Make sure that the correct mix is selected for each active output in the routing section at the bottom left. This setup will fix latency issues while you record, but the delays during playback can’t be helped barring driver enhancements or system optimizations.

What buffer setting are you using?
We sometimes track at 256. There is some delay although that can work if you stretch your ears a bit. :slight_smile:

We did use an RME Fireface at 64 samples which was barely noticeable.

For live work I have used a combination of Cubase and Focusrite monitoring - Running the main sound latency-free and simultaneously routing the signal through Cubase, adding delay, flanging, reverb. Just makes the sound bigger.

Personally I am not a fan of adding vocal effects live because they make it hard to get a good resonance.

Hope this is useful. Good luck, :slight_smile:

Not sure what changed from Cubase 6 to 7, but: The trick is to SPLIT the signal you are monitoring into a DIRECT component and a FX component !
Use latency free monitoring from your focusrite for the direct signal and from the signal that is routed through Cubase and has latency use ONLY the FX component.
In Cubase you have monitor ON on the track you are recording, the volume fader all the way DOWN and the sendFX switched to PREFADER.
This routing setup allows you to work with heavy projects and high latency settings, while still providing perfect monitoring. Its the beauty of Mixcontrol and the Focusrite that you can do this as it does not disturb if the FX component has some latency. I have the exact same interface and think it is very good. IMHO you do not need another interface…
Let us know how you are doing and if any of the tips here helped.

OK, what I want to do is the exact opposite !

I don’t want to hear the direct signal from the Saffire Pro when recording in Cubase…i just want to monitor through Cubase by activating the little “speaker” icon… Is this possible ???

For example, if i want to plug in an electric guitar, then insert an “Amp Sim” on that channel so i have a nice distorted guitar sound while I’m playing and recording it… i don’t want to hear the clean direct sound at the same time…

I used to be able to do this no probs with my old Cubase 5 and the Presonus Firefod interface…

Im currently using a Macbook Pro, with Cubase 7.5 and of course the Focusrite Saffire Pro 40 audio interface…

Hi metromixstudio!

You mute the guitar on the Focusrite MixControl application.
Open the MixCXontrol app.

Locate the input fader for your guitar.

Each input has its own fader which you can use to adjust the amount of direct signal going to your monitors. You can set the fader to zero or activate the ‘M’ button below the fader.

I can send a screenshot if you like! :slight_smile:

[Carlos’ advice is good too although I cannot verify if it has any effect on latency.]

The Reason you hear a delay is due to ‘latency’.

The signal takes time to be processed by the Pro40 and Cubase.

If you want to avoid direct latency you need to get the latency down to about 3milliseconds [ms] or less.

On my system that means setting the Saffire to 64 samples.

You edit this setting on MixControl/Settings/ASIO Buffer Size/64.

You can then check the latency of your system by going to Cubase/Devices and read the input Latency [in my system 1.837ms] and Output Latency [2.494 ms.]

The problem is the more effects and plugins you add the more latency you get in the system and the more likelihood you would have of dropouts in recording or playback.

That is why many people use direct monitoring. or use the split system mentioned above.

MixControl does have a 48 and 32 samples setting which you might try but on my system it causes dropouts on audio.

Good luck!

Thanks Galvinstephen ! That sorted my problem… Weird because I read through the manual several times and did not find that method… And it seems so simple!

Anyway…all good… And thanks again…