"SAME EQ" Settings Across the Mixer?

Hello all,
i created 20 Mono tracks. i would like all tracks’ EQ’s to have the same starting point of “Low-cut @ 80Hz” from EQ menu Load Preset. How do i achieve this without having to do one track at a time? i have tried to do this by highlighting all channels and then selecting “Link/Unlink Selected Channels” and also Q-Link at the top of Mixer. Nothing that i’ve tried will allow this. Is there a shortcut to achieve this? Thanks in advance to all. :confused:

Hi jobnow777,

you can save the EQ of your first track as a preset, and then load the preset as the starting point on the rest of your tracks.


…across several (already created) tracks at once…? (i.e. as the OP requested, more than “…one track at a time…”). I’ve tried, by highlighting several tracks first, without success… Am I doing something wrong…?

Hi Puma,

try this:

  • open the mixer
  • load the preset in one track
  • highlight all the tracks you want to load that preset on
  • press “alt + shift” on your keyword, and click the “load / save preset” button on the first track
  • drag and drop the preset to one of the highlighted tracks (keep pressing alt + shift)
  • All the highlighted tracks should now have that EQ preset loaded

Let me know if it doesn’t work.


Thanks Luis! It does work!

:smiley: Workflow just got a lot smoother!1

I think you have already been given the best solution but depending on the exact situation, these are two more options:

You can use the Link/Q-Link feature to do this AS LONG AS all your channels have the same EQ setting to begin with. Any EQ changes will then be applied to all selected channels with Q-Link enabled. So, if you have just created some new default channels, this approach will work fine.

You can also use the copy/paste key commands (Ctrl+C, Ctrl+V) to copy settings between channels but be aware that this will copy ALL of the channel settings i.e. volume/EQ/sends/routing etc.

With the “Abs” (-olute) button in the tool bar it also works with different initial settings :smiley:

Great, thanks for sharing that. Useful to know.

Oh, just discovered this was a misinformation. That’s how I expected it to work but in fact it doesn’t.