Sample Editor Manual Adjust Ignores Time Signature

I have an audio file of a song that’s in 7/4 time. I imported the audio file into Cubase 11. It was imported into the pool as 4/4 time, but I changed that in the Pool Window to 7/4. I also have the Cubase project’s time signature set to 7/4.

I want to use the Sample Editor to manually adjust the time definition, as described on page 552 of the Operations Manual. But when I enable Manual Adjust, the bar markers (the ones that are blue on top and green on the bottom) occur every 4th beat instead of every 7th beat like they should. This makes it next to impossible to do the manual adjustment.

Is there someplace else where I am supposed to set the time signature to 7/4? Or is this a bug in Cubase 11?

Windows 10, Cubase 11 initial release, Surface Pro i5.

Hi,
Could you attach a screenshot, please?

Project window, showing 7/4 time signature.

Pool window, showing 7/4 time signature that I typed in.

Beat position marker where there should be a bar position marker.

Three images showing blue/green bar markers every 4 beats.

For what it’s worth, I just tried the same thing in Cubase 10.5.20, and there is exactly the same problem.

Hi,

The blue lines are the Hitpoints (“peaks”) coming from the file, or am I missing something?

No, the blue lines are not Hitpoints. They are bar markers from the Manual Adjust feature. Those same lines would turn green if I hovered over them in their lower third.

The “Stretch Grid” popups are proof of that.

Is there any other information I can provide? I would like to see this bug get investigated and fixed, and I would be glad to help in any way that I can.

Hi,

To speed it up, would you be willing to share the Audio file, file? You can send me a link via PM. No worries, I will use it for the investigation purpose only.

I just sent you a link to the file via private message.

Hi,

I’m sorry for my delay.

The 01 Estimated Prophet Audio Event looks fine here on my side. See the screenshot, please. Am I missing something?

No problem. Thanks for looking into this.

Now you should turn on “Manual Adjust“ and try to adjust the grid using the blue upper zone for “stretch grid,“ and the lower green zone for “move bar position.“ You will see that the visual feedback as you drag the mouse horizontally seems to be set up for 4/4 instead of for 7/4. The bar indicators are in the wrong places.

I was still able to get the job done, but I had to mentally adjust to put things where they needed to go instead of where it looked like they were.

Hi,

I see, now I know, what you mean (hopefully).

When I use the Manual Adjust tool and start to stretch the blue lines, you are right, at some point, the grid switches to the 4 beats-like view. But it seems, it’s only graphic issue. If you Zoom In after, you can see, there are 7 lines again. Can you confirm this, please?

It seems the algorithm to show the grid doesn’t know, how to show the 7 beats, if it doesn’t fit to the screen anymore.

I don’t know what you mean about zooming. But let me give you a detailed description of what happens.

I select the audio event containing the song. I open that event in the Sample Editor. I turn on Manual Adjust.

I drag Set Grid Start to the second peak in the waveform, so that the 1 in the lower scale at the top of the waveform is directly above it.

I hover my mouse in the top third of the waveform directly under the 2 in the lower scale. I get a light blue highlight that’s labeled Set Beat Position. It should have been dark blue and labeled Stretch Grid.

I move my mouse horizontally to the right until it’s under beat 2.2, and a dark blue line appears labeled Stretch Grid. This should have been under beat 2, but it wasn’t.

I slide the dark blue line under beat 2.2 horizontally until beat 2 is lined up where I need it to be, and I have now stretched the grid. I am dragging 2.2 while watching 2 so that 2 lines up properly

Now I need to Set Bar Position (Move Following Bars) for bar 3. I move my mouse to the lower third of the waveform display and then horizontally to the right. I find the dark green line that I am looking for under beat 3.3. I will have to drag 3.3 while watching 3.

In bar 4, the green line will be under beat 4.4, and so on.

This happens when I am working in 7/4 time. In 4/4 time, everything works as it should.

Hi,

Sorry, could you please make a video screen recording for me?

Here’s the video. Let me know if the OneDrive share link doesn’t work and I’ll try something else.

https://1drv.ms/v/s!Aq2dTIlD9fn0iYwIvfM9GEUVWoedDg?e=9hKhCr

I previously set the wav file’s time signature to 7/4 in the Pool Window.

Here’s a different video link in case the first one didn’t work: