Sample import issue

Hi everyone. Wondered if anyone could help me? Since upgrading to Cubase 10… when I import a sample that’s at a higher sample rate it plays back slowly in a lower pitch. I have ticked “copy file to working directory” and ‘Bit Depth’, but the problem persists. I’m certain in the last version of Cubase it automatically converted imported audio to match the project settings. Any ideas? Thanks in advance

I have ticked “copy file to working directory” and ‘Bit Depth’, but the problem persists.

Tick Sample Rate too.
If “Sample Rate” is greyed out, the file has the same Sample Rate as the Project.
If you have ticked “Please, don’t ask again”, you can show the Dialog again in Preferences -> Editing -> Audio -> On Import Audio Files -> Open Options Dialog.
You can check the Sample Rate of the files in your Project in the Pool (Project -> Pool) and you can also convert them there via right click (un-undoable), which will change the lenght of the events of course.