Sample offset in batch converter - bug?

I used the batch converter to convert short wav files 96KHz into ogg files 44.1KHz. The resulted file has a sample offset. The waveform comes about 1600 samples earlier and the beginning of the waveform is cut off. I haven’t tried to find out if the problem is in sample rate or format conversion (or both).

Any way to get around this problem?

Mono, Stereo files? What Ogg settings? I did a test and everything is ok here.
And what do you call a “short wav file”?

wave files are about two seconds. Ogg files are stereo. CBR/ 192kbps

Just tried with a 44.1k stereo file to convert to Ogg CBR / 192 with the batch processor, with WaveLab 10, and no problem.
Maybe you are using some plugins?

Hi Gerrit
if you use your Spaces 2 plugin then you have to know that this plugin gives problems with Wavelab when you using the standard settings in Spaces 2.

If that is the situation then I hear from you and i can give you my settings.


The original wav files were 96KHz/ 24bit. So maybe it is the sample rate conversion. No plug ins. Just the batch converter.

Just tried with 96kHz source,… all is fine.

Thanks a lot for testing. That is weird. I tried on multiple mac computers. I can work around this problem but would be interesting to find out what causes this problem.
Should I send some audiofiles?

I tried on Windows only…
I will try on Mac next week.

I have now tried on Mac. Still ok.
This being, you could try this: set the sample rate to 44100 in the file format dialog. This will cause WaveLab to do the sample rate conversion before Ogg tries to do it. Maybe that helps.