Sample rate debacle. Interface & DAW at different samplerate when recording. Playback, export ruined

English is not my first language so I’ll try my best to be concise.

  • Noob. Rookie at studio recording and first time recording live event. Small gig.

  • Mixing console used was the Soundcraft Si Expression 3. Missing USB module for multi-track recording so was forced to use an Audient Evo 8 to take direct signals from the console via XLR cables.

  • None of the equipment was mine but everything sounds fine during the event. But used my Windows laptop for recording.

  • Come home, open project in Cubase (with my own USB interface). Playback is slowed down and pitched down.

  • Borrowed the Audient Evo 8 from the event. Turns out the EVO settings thingie that you access from the right side of the task bar shows that the interface is set at 96kHz. But the project is at 44.1kHz (which is my default).

  • Even the WAV files in the “Audio” folder of the project folder show that they are 44.1kHz and they sound slowed down and pitched down in Windows Media Player and VLC.

  • Open project, set sample rate from Audient Evo thingie to 96kHz. Message appears on Cubase and I click “Allow different sample rates”.

  • Playback goes to normal.

  • I render/export the project as a 44.1kHz WAV file. Rendered file plays slowed down, pitched down.

HELP!

Please ask me any questions in case I’ve left out relevant details.

When bringing these recorded files (at 96k) into your Cubase project, you will have to ‘import’ them, not just drop them in. So make sure that you create the Cubase project first using your sample rate setting (44.1k); also set your tempo so the tracks can be aligned to the grid. Now go to your file menu and go to import files; select your files and I think it says ‘open’ ; you can do them all at once. A dialogue should appear asking if you want to convert to the project sample rate and bit depth; say ok. That should bring them into your project playing at the correct speed. Hope this helps.

Pretty sure sample rate change on import can’t help when the file sr is different to the header info…if you import to 44.1k project it will think they are already 44.1k and if importing to another SR it will get speed wrong as it’s working on the basis they are 44.1k.

You need to correct the info in the header using this for example:

http://www.railjonrogut.com/HeaderInvestigator.htm

Once the headers read 96k same as they were actually recorded then you can sample rate convert on import or set project to 96k and should all work fine.

1 Like

Dropping the files from explorer or finder on to the timeline means importing them into the project. It’s the same as the import dialogue.

That’s not true, why should the software think these files are at 44.1?

Because the recording software was set to 44.1kHz and thus that value is written into the header.

You have to disable your onboard windows audio so the soundcard is the only device. Then set the windows audio to that soundcard and match the SR you want.
THEN open your DAW and set the rate to the same…
Sometimes when you have your onboard audio in the bkg it’ll create this exact issue.
If not, i’ll leave this here for someone else :slight_smile:

This is a weird piece of advice. If you have 2 audio devices why would the device that is not used in Cubase interfere with sample rates of files used inside Cubase?
Perhaps the rest of your advice might be sound but to me it seems disabling an on-board soundchip is a bit over the top.

I would really go with the software that @Grim suggested. Seems to be the easiest way of fixing the dilemma.

Or are you proficient in editing files with a hex editor? Then google for information about the header of a wave file in order to find out which bytes to change.

Of course it’s true…the sr info is written to the wav header on recording and Cubase was set 44.1k so it writes it as 44.1k. This is exactly why it renders at wrong speed, Cubase thinks it’s a different rate than it really is.

Getting deep into the weeds here. It was explained to me like this: Think of one second of music as being put in a box that has room for 44.1k of samples for every second of audio…lots of boxes. The box size was established when you set the sample rate in your project. Now you copy (not import) a 96k file into a these 44.1k boxes. So the program jams each second of audio into these 44.1k boxes (the box is actually called a ‘word’…so a 44.1k word) . Now the program jams all 96k samples into the 44.1k word and tries to play them back; it plays the 96k audio back over twice as fast and higher in pitch.
Now if you import the file, Cubase (and every other DAW) resamples it for you so it fits in the 44.1k word…and it plays back properly.
All this header info and sound card choice doesn’t enter into it unless you have software that can let you use to sound cards at once. I have my Windows audio card available but I never use it; I use my RME audio card for everything. Hope this helps.

Weird? Because that’s my experience and not yours?
Fact is that Windows will change the sample rate and select the SC on you if you have both enabled.
ftr,
I’ve built my workstations since the late 90’s and when I 1st went with my outboard SC (MOTU 2408mk3). Windows would take over and choose the onboard sc and choose it as the primary so I disabled it and it worked. But updates sometimes “re-enabled” the onboard so I did 1 better, I disabled my onboard card in the BIOS. With that, only my outboard (Goliath HD) is used and it clears up all the headaches of Windows.
This particular affected me big time because of the customization of BYO so I know Windows ability to do that even when using the added SC!
OTN…I speak from experience not a shot in the dark, or a guess…
You eliminate MANY audio issues by doing this very thing especially since it totally eliminates ANY frequency changes which ELIMINATES this very issue.

That is so awesome that you built workstations back then. Hey, I had a Motu 2408 Mk1 additionally to a SoundBlaster16 chip back in the 90’s. Awesome card. I only replaced it after a couple of years because I got my hands on an RME Hammerfall.
So, what do you think is the reason for Windows changing the ASIO driver in Cubase and then also the sample rate?

1 Like

Nothing wrong with what was explained to you…but it’s not relevant to the issue at hand.
The OPs files will import without giving the option to resample because as far as Cubase knows they are already 44.1k. In fact he said already they are running fine in his 44.1k project. The problem only appears when you render and then you get the speeded/pitched up render/mixdown.

Fixing the header is the ONLY fix for OPs problem. The software linked exists purely for this purpose.

Actually, just remembered that wavelab can also edit the properties of the wav header so another option to that software is to open in wavelab, open the file properties and change the sample rate flag, then resave as correct sample rate.

Yea, I still have it… The mk 1 is a classic…lol

It’s a simple thing as windows configuring your settings for you…when you shouldn’t really let it.
The thing you have to remember is that the audio files and the DAW settings should be at the exact same settings… So boom, you set that up then, If windows is given choices sometimes, inexplicably it’ll go w/the OB SC which may be set at a different rate (or not) but then change because you have different sample rates enabled within windows audio settings.
So when you render it’s one rate and play back it’s another so it sounds wonky because of it.
The thing is you have to tell Windows to ONLY use the rate you want so everything matches and nothing shifts at any point.
if it’s 96k then that is the only rate to enable, 48k same…
…Unfortunately,
Many times the user just doesn’t want to do the necessary steps to disable the OBSC because they’re using their everything computer instead of a dedicated machine.
As I said, this USED to happen to me and I’ve spent countless hours making sure that exact thing doesn’t happen.

Either way, that’s my conquering my windows audio story… :alien:

Wow…that’s a lot of problems…well, solved problems…congrats to all.
Personally, I’ve always used Windows (I don’t own any Apple products) and have used Cubase since it was called VST32…before SX1. I’ve used a number of sound cards, never using the internal SC in Windows. I’ve never experienced any of these issues, so whatever I didn’t do worked for me. I’m on C13 Pro running Win 10, Intel i7, 64G of ram, through an RME. I can run several hundred tracks (midi orchestration) without a glitch. The problems are usual due to my small UAD2 card when using their plugs. Cubase Pro has always worked the way I’ve expected, so my point is to say, when everything is setup correctly, everything will work. IMO, it has nothing to do with Mac or Windows or what SC you’re using. Just keep working on it and the problems eventually reveal themselves…with a little help from your friends. Cheers.

1 Like