Sample stretching upon wav import

I import a 1sec snare drum (44kHz 24bit wav file) and it stretches into a 10 second sample and sounds terribly distorted (well, like being stretched 10x).

What makes Cubase do that and how to fix it?


Make sure Musical Mode is not enabled on this Audio event, please. You can do so in the Info line (while the event is selected) or in th Pool.