Sampler track crashing(doing it again)

Well since I never had a response back how to solve this I might have found the solution.
I have deleted the xml files from the appdata/roaming\steinberg\cubase11 pro folder. I removed the blacklist files of VST2, VST3 xml files and I also removed the vst2 path xml files. After this you need to add the paths again in the vst manager. For example if you have a harddrive D: with plugins you have to add that drive\folder again. After that you can rescan all the plugins and like a miracle the Sampler works and doesn’t crash anymore.

Maybe this can be of help to someone.

Good luck.



So trashing preferences helped. Do you still have the old preferences backup available by any chance, please?

I also didn’t get the crash when I disabled 3rd party plaugins, Robert. However, I found the problem to be this for me. You can try it: Cubase Crashing Video - Create Sampler Track Issue - YouTube

Tried it… still the same.

Hi Richard_Richard!

I would like to thank you because this solved the issue! However I needed to do a few more steps. In the meanwhile I updated to Cubase pro 12 and the sampler started crashing again. In another topic I’ve read that Cubase 12 has some compatability problems with previous xml files of Cubase Pro 11. Before removing the C:/programfiles/steinberg path I needed to delete all cubase 11 preference xml files. You can find them in C:/users/appdata/roaming/steinberg folder. When you’ve updated from 11 to 12 you can find both folders in here. Just delete the preference xml files in the Cubase 11 folder and make sure you also check the subfolders if there are any preference xml files including the keycommands and profile xml’s. Also delete the vst2 blacklist xml file in here and the vst3 blacklist xml file in the subfolders. Then follow the steps of your tutorial Cubase Crashing Video - Create Sampler Track Issue - YouTube
by removing the C:/programfiles/steinberg path and update the path and after that update the vst’s. Restart Cubase and you’re good to go.

Many thanks and good luck to you who still struggle with this issue.

Greetz Vincenzo

1 Like

Hi Robert,

You could try the extra steps I’ve made. See the post above this one.

Greetz Vincenzo

Thanks a load! It finally works after all these years! Followed your post and the YouTube video and it worked…thanks.

1 Like

Also I found out that If I try to drag .rex file or right click “create sampler track” from the browser on the right side, Cubase crashes, but If I add the .rex file in the project folder from the “Pool Window” and drag the .rex file from there, or right click again and use the option “create sampler track” it loads perfectly fine with no crash. So it is issue with the build in browser on the right side of the screen.


We’re call this trash Cubase preferences.

If this really happens, this is clearly a user error. The user asks Cubase to handle non-VST-plug-in DLL file as the VST plug-in. (Unfortunately VST2 plug-ins were using the DLL extension; luckyli VST3 plug-ins are using *.VST3 extension, do they cannot be mixed up with other totally different kind of files.)

Sorry I’ve only just read your reply, but I’m glad I could be of help!

Hi Martin, sorry, but I don’t understand what you mean by me "asking Cubase to handle non-VST-plug-in DLL files as the VST plug-in. As the user, it is my job to select folders in which .dll files, & .vst files are located. Cubase should be fully compatible with all of those particular files because the Cubase installation itself put them all there, & therefore these should be the most stable files for Cubase to work with. If Cubase doesn’t want to read or recognise a particular file, then I wish it would do so without crashing.

Really, at the end of the day, as normal Cubase users, we simply want to be able to sit down at our computer, switch Cubase on, & use it. We shouldn’t be expected by Steinberg to have a PHD in Computer Science in order to prevent constant crashing. Anyway, we can agree to disagree. I just try to hold on to my dream that I can one day turn Cubase on without these kinds of things always happening! :face_exhaling: :expressionless: :face_with_peeking_eye: