Sampler Track volume


I’m using Cubase 9.5 Pro. When I play a sample in a standard Audio Track, the volume is good. But when I play the same sample using a Sampler Track, the volume is really low. So low that I cannot get it to the original volume even by setting every volume all the way up. Note that I already set “Velocity” to 0 in the Sampler Control’s ADSR window (to ignore MIDI velocity).

What am I missing?

Sounds like a MIDI issue, I’ve just tried it without manipulating the midi in any way and it’s fine. The velocity is 100 to 125 when i use it normally.