Sampletank and Virtual Midi

Has anyone managed to get sampletank and virtual midi to work within cubasis? I think I’ve got everything set up correctly but I’m not getting a response from Sampletank.

In cubasis I’ve set the channel to a midi instrument with Virtual Midi set and Sampletank set on channel one but doesn’t appear to be working. Any help would be great.

By the way, this is a truly incredible day when my entire studio of ten years ago which took up a whole room and cost thousands can be replaced by an ipad, an App, an Alesis io dock, a mic and a keyboard… Great work Steinberg and I’m sure despite the skeptics you’ll deliver the next level via updates!

I’ve not been able to get it to work either. Must be a bug :frowning:

Also tried using it with midibridge also. Still didnt work.

I can’t get MIDI Guitar to work with Cubasis either. Works fine controlling other apps that support virtual MIDI.

You said it!! I used to have 2 keyboards, a drum machine and a mixing console PLUS a laptop! I can’t believe i am getting these tracks done on an ipad mini that can fit in my pocket! Sometimes it does feel like a toy, but that was the same outlook laptops had 6 years ago. I think Steinberg has paved the way for the new standard in ipad recording, and the best part is, new updates come everyday for different apps, so imagine what version 2.0 of Cubasis will have feature-wise. Not to mention the more powerful processors to come with future ipad releases with make more things possible!..

For the first time in a while, i feel like i will no longer need my laptop as my primary production tool. i have always hated using the mouse while making music…the touch gestures of a tablet make production a much more enjoyable experience for me…sorry for the rant, lol, oh yea, and no go for Sampletank either…matter of fact, Cubase won’t even play audio when i open ST, weird.

I strongly suspect this is yet again an IK Sampletank issue. Ive tried getting ST iOS to work with Genome MIDI and other MIDI generating apps and it always seems to be Sampletank that is a problem.

Today i tried Soundrizer with Cubasis with no problem. And BS16i works fine too.

Sampletank is a pain to get to run in the background. IK need to get their act together and sort this out.

I also tried the iGrand Piano with Cubasis - and it didnt work either.

I’ve just posted on the IK Multimedia forum about this incidentally.

Hi guys,
For me it worked selecting in Cubasis as an output of a MIDI track “Virtual Midi”. :slight_smile: Then I could trigger Sample Tank in Cubasis.

Crohde, are you sure you’re not triggering internal sounds in Cubasis. I’ve tried everything and can’t get it to work. Please post your settings in Sampletank and Cubasis. I hope you’re right. Thanks.


we had issues regarding the communication between Sampletank and Cubasis. The uncommon Buffer Size of Sampletank was identified as the cause of that issue when we tested it. So the cause of the issue seems to be Sampletank.

Kind regards,

I was referring to the message by Carlos saying he got Sampletank to trigger from Cubase.


sorry for the confusion. I just wanted to indicate with my message that we indeed experienced issues between Sampletank and Cubasis in certain setups.

Kind regards,

I have managed to get Cubasis to work with Arctic Keys however still no joy with Sample Tank. Even weirder… I cannot get SampleTank to even trigger using the Alesis IO dock and the Q49 Keyboard controller! It only seems to want to communicate with itself.

Also I notice in Cubasis that Sample Tank does show up in the Midi settings but still doesn’t trigger. I guess it’s a definite IK thing then based on some of the comments above.

I’m using an iPad 2 with 16GB stripped down of all apps so have a good few GB space.

Cubasis works fine with Garageband , SoundRizer and a GM modile ( DB16 ? ) its just Sampletank that
fails to cooperate.

Real shame since it has some of the best samples.