Save Times (improved with East West Play 4.3.1)

Dear Steinberg,

Is there any solution to minimize save times? Would a fancy RAM disk allow for fast writes and minimize the save time issue? Desperately want to fix this since waiting for a project to save is a huge interruption in my workflow. Thanks

No doubt a fast SSD would reduce your save times by X amount. Maybe think about a Samsung EVO 250 gb for the projects your currently working on and move them off to slower storage after that

I tested this on an Samsung 850 EVO 1TB and unfortunately it still takes about 10 seconds on a default template (when i start to add lots of plugins it gets worse). Perhaps it’s not the write speed but a limitation of cubase.

How many tracks ?
I usually don’t have that big projects that I even notice it. On a 100 audio track project it takes one second to save.
And only that long if I use a lot of plugins.
Try to start Cubase in safe mode, and load and save a few projects.

It seems to be linked to VST instruments as far as I’m aware (e.g. stuff like East West Play). It’s really annoying :frowning:

I did a test and one example of Play with a large Violin Legato patch added something like 3-5 seconds of saving time IIRC.

My save time never seems to be more than 2 seconds and is consistent from one project to another.

I had really slow wait times as well with 7.5, and posted last year about having to wait seemingly forever for the Windows ‘hour glass’ to disappear.

For me the answer was to right-click on the Cubase start icon and then click on Properties.

I had to un-check Run in compatibility with Windows 7, and that fixed it - to no more than just a second or so.

Something you can try.

If you use a lot of memory intensive VI’s you’ll get long save times - it’s not just a Cubase issue. I was using EWQL Hollywood series more & more & my save times were becoming unworkable (I auto save every 2 mins).

I got around the problem by hosting Play in Vienna Ensemble Pro & decoupling it from the DAW. Works really well & gets your save times down to normal. I use it all the time now for Play, Kontakt & BFD3.

I have a project that takes 48 seconds to save and is over 50MB in size. That’s roughly 1 minute lost every 10 minutes (my save interval). So after a 4 hour work day on this project, 24 minutes are spent waiting for Cubase to save. That adds up fast…

Oh one thing I did and forgot about was, disabling the automatic hitpoint detection in the preferences. I can do that just fine manually when I am going to use hitpoints. That at least brings the size down.

That seems like an awfully long time for each save. I’m not sure what else to try there apt - sorry.

Even my heaviest projects only take 2-4 seconds to save, if that.

I was working on a mix of a 2 hour live show and save times became 5 minutes by the time I’d finished :open_mouth:

I disabled auto-save for the duration and Cubase was very reliable throughout, nothing but simple editing and working on the mix, so everything concluded admirably :slight_smile:


I’ve recently had my save times go up in 7.5 projects as well. Using plugs or not, there is always a pause in the action whenever the auto-save kicks in or manual (anywhere between 10-20 sec). Interestingly, when I open these same projects in 8, there is NO pause when saving. It’s something in 7.5.

Thanks for the input everyone. Disabling hitpoints reduced it from 54 seconds to 50 seconds. I tried saving on my Samsung 850 Pro with RAPID MODE enabled, (which is showing 4,160 MB/s write and 5,109 MB/s read under crystal disk mark). It saved in just under 47 seconds.

So this leads me to believe this is not going to be resolved by hardware improvements anytime soon. So has this become a feature request and we should move it into the feature request forum? I think we are asking for background save feature.

Looking at the different threads on this there seem to be two distinct things that create long save times, 1:Hitpoints, 2:Large amount of Kontakt/Play VST instruments (or similar). I’m definitely in the latter camp.

Anyway, I bit the bullet and bought Vienna Ensemble Pro as has been suggested here and elsewhere and it makes a huge difference when you host your VSTs within this (in decouple mode). It’s a slight pain to have two tracks per instrument, but when the upside is instantaneous saves I’m not complaining!

Hello all,

I also noticed that save (autosave) times increase substantially when I start creating scores from tracks (for the brass section and the keyboard guy).
I’m autosaving every 5 min (maybe I’m a little paranoid) so I see it pretty often. I have an SSD as main (C-Drive) hard disk but projects and libraries are stored on two separate 2 TB normal HDDs.

Since I am not making a living out of music, I can live with it.



jiminy christmas. I updated to East West Play 4.3.1 which claims to have improved save times. My save time went from 54 seconds to 19 seconds. Hooray! :ugeek: :smiley:

Maybe update your title to ‘Save Times_Solved- East West Play’ to maybe help other users. I use play 4.3.1 aswell btw

regarding VSL ensemble PRO, with non decoupled instruments that are Sample and disk intensive the save times can increase substantially.

Update I realized that I was getting close to maxing out available space on the audio drive I record to. I freed up most of it and my save times are now down to only a second or two on bigger size projects. Fixed it for me.