score display of same note on multiple MIDI channels

I’m trying to make the transition from Logic X to Cubase, and I’m still getting familiar with Cubase. One thing Logic seems to do with not too much tweaking of the score preferences, is to by default display the same note on multiple MIDI channels - as a single note in the score display. Yes, you could create a score set to display the (same) notes on each MIDI channel as a separate line in the score, but I seldom want to do this until the final piece of music is complete. When working on the music, I usually just want to see a single line or a single instance of a note even if it is duplicated on multiple channels.

But Cubase 7.5 seems to always want to display 2 instances of each note (and not just 1 or 3, i.e., the same note in the right hand is on 3 MIDI channels so I would think that if Cubase is going to display more than 1 instance of the note it would display 3 notes instead of just 2).

I tried editing the duration of the notes in Cubase for a right hand F major chord so that their duration in the MIDI event list is the same. (For an F chord in root position, I have 9 notes, or 3 F’s, 3 A’s, and 3 C’s, on MIDI channels 1, 2, and 4). Or, I realize the timing for the notes may be different on each MIDI channel , and so I thought maybe Cubase is being more precise about this and therefore shows me 2 notes on the staff instead of 1 note on the staff. But editing the note duration in the event list that did not seem to work either.

I’ve attached some screen shots to show what I see in Cubase and Logic. Happy to learn if Cubase can “collapse” or glob together MIDI data like this to show up as 1 note on the staff.
F_chord_Cubase_after_edit.png
Cubase_score.png
Logic_score.jpg

I’m reading (deep!) between the lines here :wink:… just by looking at your first Cubase screenshot.
If, as your starting point (let’s just talk about the right hand for now), the duplicate notes were on channels 1, 2 and 4, then the Polyphonic voicing settings I see there should only show notes on the upper staff that are on ch #1 (2 and 4 shouldn’t even be visible!).
I am guessing that this is what you did, and what happened as a result (not saying it’s your fault though :wink: )…

  1. When you opened that Part in the Score Editor, Polyphonic settings was set at “Single”? (which showed all the duplicated notes)
  2. You changed the setting to “Split” (with, maybe, the default split note at middle C… doesn’t matter though :wink: ).
  3. You then changed the setting to Polyphonic, and used the piano Preset?
    If so, you inadvertently reset all the upper staff channels to ch #1 (hence the multiples again).

If you still have the original, unmodified, go back and, this time, change the setting to Polyphonic manually.

(Remember that, for this quick test, I didn’t even bother with the left hand, but the rules are the same :wink:
If you set the voices #1 thru #3 (for the upper staff) to channels 1, 2 and 4, it should now look like this…
Poly_3 voice.jpg
Or, if you choose to activate only voice #1 it should look like this…
Poly_1 voice.jpg
But, of course, you won’t be able to edit any notes that aren’t visible :wink:.

Another, completely different, approach, would be to select all notes whose channel is 2 or 4 (using the Logical Editor), then open the Edit Note Info dialog (or click on the “I” icon when notes are selected), and change the note head from “Auto” to blank (and, in the same dialog, set “Ties” to “Hide”).
(I did just try selecting those 2 channels and simply “Hide”, but it didn’t Hide all the expected notes… can’t figure out why not, for now, but anyways, the note head method does work :wink: )

Thank you muchly for the reply. I think that you are correct that I changed from the default mode of “single” to “split” with piano, and then went to “polyphonic”. (A score set of piano - which has a split point is what I often use in Logic).

But I only have the current copy of the Cubase file I saved from the screenshots I posted. If I manually change back to single, I get all the notes on one staff. I can get pretty much get the same result that is on my posted screenshot with either polyphonic mode (voice 1 = MIDI ch 1 for G clef, and voice 4 = MIDI ch 3 for F clef), or with split mode. But either way I still get the doubling of notes as seen in the screenshot. I can select each exploded MIDI part and get it to look correct for the left hand or the right hand - as your screenshot shows for the right hand.

What I don’t get is why polyphonic mode still shows the doubling of note heads on the score, e.g., in the right hand, when only MIDI ch 1 is assigned for a single voice in the G clef, and only MIDI ch 3 is assigned for a single voice in the F clef. This seems like a bug to me, i.e., it looks like the score must still be displaying MIDI channel 2 or 4 (even though those are not assigned to any voices). It’s a different model compared to Logic to by default assign MIDI channels 1-4 to voices 1-4 in the G clef and MIDI channels 5-8 to voices 5 to 8 in the F clef in Cubase’s polyphonic mode.

I have not tried using the logical editor as you mentioned in your second reply, but I will.

I actually filed a ticket with Steinberg, but they have not been able to give me an answer. The product rep Greg Ondo (he’s the guy who does many of the videos) also tried to help me with this. But so far I think you have done a better job of trying to help me get this to work from the original non-exploded MIDI track :wink:

No… like I said, you inadvertently actually changed chs #2 and #4 back into ch #1 when you used that Piano preset, so the polyphonic staff is actually telling you the truth! :wink:.
So, because you no longer have the original Project…you could, if you need to, “rebuild” that original part (with its multiple MIDI channels), by Soloing all the Tracks with the Exploded Parts (making sure that, for each of them, you set the output channel to “Any”), set Left and Right Locators to the boundaries of the desired Parts, then, MIDI menu>“Merge MIDI in Loop” (Be sure to Solo the Tracks, or else it will merge any other MIDI that happens to be playing :wink: ).

(on a more general note… once you’ve gotten this problem sorted out, and once you are happy with Polyphonic staves in Cubase… I’d recommend you to always favor Polyphonic Staff over Split Staff, which is far less user-friendly than in Logic, where you can freely draw the split point… in Cubase, as you have already noticed, you effectively move notes (in polyphonic mode) by changing them to the appropriate MIDI channel.)

Sorry for the delay in getting back to you. I played it in again from scratch to create a new recording, and yes I see what you mean :wink: - good to go from single staff to polyphonic staff setting, and then set MIDI channels accordingly for polyphonic voices. It is neat that if you happened to set your split point wrong for some notes in the MIDI part for the G clef, then you can simply drag them to the F clef and assign them to its MIDI channel instead. Now I’m curious to know what people use split staff mode for however.

It’s just a “cheap ‘n’ cheerful” method for very basic piano-type scoring. I guess, when Steinberg realized that something a bit more sophisticated was needed, they went directly towards “Polyphonic Voices” rather than just doing a variable split point, à la Logic.