Score Editor feedback (bar spacing, auto-scroll and side zones)

Hey folks, I’m having a few issues with the Score Editor, please refer to the following video/timestamps:

  • 0:00 how can I have bars 2 and 4 NOT stretch due to the 32nd notes in the harp staff? I changed the notes type from Normal to Graphic, which fixed the spacing, but it seems not possible to group graphic notes. Any workarounds? I would prefer to not change the original notation.

  • 0:09 when I open/close the side zones, the score jumps to the top. Any way of preventing this behavior other than having the zones always visible?

  • 0:26 the screen shakes a lot when I have auto-scroll enabled. It feels like Cubase is unable to keep vertical focus, depending on which staff I have selected, causing heavy eye strain.

Thanks in advance, always appreciate your time and help!

What do you mean exactly?
I presume you well know that you can move bars very easily in the Score Editor.

00:09 What Cubase version are you using here?

00:26 It seems to be a graphics card/driver issue.

Please put your computer and software specs in your profile.

What you would do in Finale...

In Finale 27, you would deactivate the “Automatic Music Spacing” option and then make sure you don’t apply automatic music spacing to that measure. This option would though be valid only if you don’t mind having measures this wide.

If you want the measure to be narrower (to be reduced, say… 4 times), you would make the first staff time signature independent. This way, the 32nd notes will not bump into each other (screenshot example 1), but rather be distributed evenly from the 3rd beat until the end of the measure (screenshot example 2).

Screenshot example 1 (notes bumping into each other)

Screenshot example 2 (notes distributed evently) - GIF


I think that the only way to acomplish this in Cubase is by using graphic notes with hidden flags (then adding flags—beam—manually). Look (hit the play button if the GIF doesn’t automatically starts the playback):


  1. Make this macro and bind it to a computer keyboard key.
  2. Everytime the window scrolls up (when opening/closing one of the zones), execute the macro twice by using the bound key.
    If you think 600% is too much, feel free to change it to a smaller value (or simply to “Fit Width”).

Open the safe mode dialog and check the “Disable program preferences”, then press ok. (learn how to do this here). Does the problem persists?

Hi Maestro, Cubase 12.0.40 and 12.0.52, fresh installs. I’ve tested on three different computers running Windows 10 and Windows 11, and they all do the “jump to top” thing, and have the auto-scroll shaking issue.

AMD 5950X, Radeon RX 6600 (Windows 10 Pro) @4K
Intel 13700KF, GTX 1070 (Windows 11 Pro) @4K
Intel 1165G7, Iris Xe (Windows 11 Home) @1080p

The shaking happens after a certain zoom level, and vertical scroll position. I’ve attached a test project, it’s really easy to reproduce: Score_Editor_Test.cpr (312.2 KB)

  • Load the project (it should have the Score Editor opened with 16 tracks)
  • Fit Width
  • Enable Auto-Scroll
  • Space bar to play
  • Change staves using the down arrow key, until the screen starts shaking

It seems that Cubase is stuck between vertical positions, and can’t snap properly, thus shaking violently. :smiley: I hope that makes sense and the video helps, I don’t know how else to explain it.

And here’s the “jump to top” bug I’m experiencing:

I don’t have a Mac at the studio, so I can’t tell if those are Windows only issues, however I can 100% reproduce them on three different Windows systems (all up-to-date and well maintained), and two different Cubase versions. Are you on Mac or Windows?

Thank you!

1 Like

Hi Alin,

Yes, that’s what I ended up doing, it looks good enough (just need to repeat the process a few more times haha). It would be really useful if we could group graphic notes the same we can with normal notes.

Fixed Spacing

A couple of questions:

  1. do you know if it’s possible to customize the beam lines thickness? (other than creating an user symbol)
  2. How do you enable the red guide lines when you drag the noteheads? Those look really handy!

Thank you for the macro, but it doesn’t seem to be working for me, was it supposed to scroll back down? By the way, does the “jump to top” thing happen to you?

Unfortunately the problem persists. I’ve tested on three different Windows systems (kindly see my previous reply to Maestro). I believe you are on Mac and it doesn’t happen to you?

Thank you for your thoughtful response, truly appreciate it!

1 Like

Quick update, I did some more troubleshooting and figure out what is causing the Score editor to shake: display scaling.

In my main computer, I have two monitors at 125% scale and one at 175% scale. The Score editor window is usually in one of the 125% screens. In Cubase preferences - General, I had “Application Scaling” option set to “Use System Setting”, so as soon as I set it to -25% (thus making the overall scaling 100%), the score stopped shaking. Anything other than 100% scale (aka, no scale) will cause the Score editor to shake when the conditions mentioned earlier are met (autoscroll + zoom + vertical position).

In sum: If Windows is at 125%, Cubase needs to be at -25%. If Windows is at 150%, Cubase needs to be at -50%, so on and so forth. Unfortunately, there’s nothing I can do for the 175% screen, since Cubase only goes down to -50%.

I also checked one of the slave PCs that has a different set of monitors and scaling options, and this behavior was consistent. I will have to live with the fonts being 25% smaller, until this is properly fixed, but at least we know the cause.

Mods, should I add a bug report?

1 Like

I know. It’s not very practical…

Must be some kind of limitation…

I’ve created a feature request (here).

I don’t think these guides can be enabled or disabled. Maybe they appear because I’m using a Mac? …

Yes, provided that you have something selected.

On a sad note, yes.

Yes. The score view doesn’t shake on my Mac. Even though I changed the display resolution to a scaled one.


This is something Macs can’t do… (have different scallings—appwise) :sob:

1 Like

There’s actually an option in Preferences, I had no idea:


Mine had the “Show Horizontal Line” disabled.

Thanks for confirming!

Thanks again, and yes, I heard back from a few friends that use Cubase on Windows and Mac, and only the Windows guys could reproduce the scaling issue on the score editor.

I’ll create individual bug reports for those. Appreciate your help!

1 Like

A post was merged into an existing topic: The future of the Score Editor