Score Editor in Cubase 10.5 Artist

Good evening,

I have my yamaha CP1 connected to the STEINBERG UR 22 AUDIO interface; when I open a midi track, I have to select the track each time to open the score editor and thus see the notes appear on the staves below… we cannot see the midi notes appear at the same time as j press the keys?
Thank you.

Activate “Record in Editor” in the Score Editor window or in the Lower Zone as shown below:



Go from the menu to Transport and set MIDI Record Mode to “Merge”


PS : These screenshots are from Cubase Pro but you have the same options in Cubase Artist.