Score Editor not updating with new parts

I have setup a Workspace which consists of the Score Editor, which was opened by highlighting the tracks (not parts) that I wanted in the Score Editor then clicking CTRL + R.

However, when I create new parts on those tracks they are not showing in the Score Editor. I have to close the Score Editor and then re-open it to show the new parts. Even clicking ‘Force Update’ does not refresh the contents.

Is this a bug, a “feature” or is is just me ?

I think it is normal behavior…
(I presume, from what I am reading, that you have enough screen “real estate” that you can still access the Project window while the Score Editor window is open?)
It should not be necessary to close the Score Editor window, however. Just hit Ctrl+R again.

On my Score workspace, I’ve maximised the Score window so that I can’t actually see the Project window.

I tried CTRL+R when the Score Editor is already open but it doesn’t refresh the content.

To be clear, I am only talking about new parts not being shown. If I edit a part which was already shown in the Score Editor then that change is reflected. It’s just when I create new parts that I have the problem of it not appearing.

What I don’t understand, then, is, if you can’t even see the project window, how are you creating those new Parts? :confused:

As regards what gets refreshed, if no Part is highlighted on the track, then Ctrl-R should refresh the staff for the whole selected track (or are you in fact adding new tracks, not new Parts?)
If a Part (or several) are highlighted, then only those will be refreshed.

It’s a different workspace. I have my regular Workspace setup for recording and then a workspace for looking at & editing the score.

What I’m trying to do is to have a workspace that always shows the contents of specific tracks, but it seems impossible.

Now I’m really confused… because it does work here (I thought it might have depended upon the setting in Preferences>Editing>“Link Editors”, but it is working fine here, even without that)…
I have 2 Workspaces created, one for the main Project window, and another for opening the Score Editor (Page Mode). N.B At least one Part has to exist on the track, else the Score will not open.
I created a Part on a MIDI track from bar #1 to bar #9.
Used my key command for Workspace #2, and the Score Editor opened, showing bars 1 to 9.
I then used the key command for Workspace #1 (the Project window), and created another Part, on the same track, from bar #9 to bar #17. I then simply clicked outside the Part, to deselect everything.
I hit the key command for Workspace #2 again, and the Score now shows from bar #1 to bar #17.

I’ve left the studio for the day so can’t check yet.I was not deselecting parts before changing workspace. But I’ll be surprised if either of those make a difference because if you’re changing workspaces then the part selection will be different on the new workspace anyway.

It’s good to know it works for you though, and I’ll try it as soon as I can.

(afterthought… dunno if this will make any difference, but…)
Was a Part selected when you created the Workspace for the Score Editor window? (try rebuilding the Workspace, with just the Track selected)

Well, I just tried this and it’s not working for me at all. I rebuilt the Workspace as you suggested. I even tried a completely empty file without my settings and it still doesn’t work. And I tried Cubase 5.5: no difference.

I also tried just one workspace with a project window and a score editor permanently open, and the score editor never updates when I create new parts, even if I hit CTRL+R to refresh the currently open score.

This is a complete workflow killer for me so I need to find out why the score editor doesn’t update when all the other editors do.

Could you possibly PM me your Preferences file, just incase there is some option you have that I don’t ?

Just to clarify, on the second workspace (ie ‘Score’), you are selecting the tracks (only) you want to see, hitting CTRL+R, then going back to the main workspace, recording something, deselecting any highlighted part, then you return to the score workspace and your Score Editor is showing your new part, yes ?

I’ve just tried with a completely fresh Preferences folder, and a new Empty Project (so, creating new Workspaces), and it isn’t working here either now :cry: :confused:
I’ll try to see if I can pin it down, but it does, at first glance, seem to be more related to my Default Template, than to my Preferences folder.

:cry: really ?!?

I was going to trash my Prefs on Monday morning, install on a new PC, etc.

This is very strange … naturally I have put in an email to Steinberg tech support but I’m not holding my breath on a reply as most of the time they don’t bother.

Presuming you still have the file where “it” worked, I’d be happy to take a look at it and see if I can figure out why that one works when mine didn’t and your empty one didn’t

I don’t think it’s that simple… it isn’t always working here now (seems to depend on the order in which I open Workspaces, and in various projects), and, additionally, those Workspaces are stored with the Project (via “Organize Workspaces”), and, obviously take into account the resolution of my two monitors here… even though you should be able to open this Default Template without problem (btw, it isn’t an *empty" project :wink: ), I think it would be just asking for trouble if you tried to call up those Workspaces.
Don’t worry… if I do succeed in pinning this down, I’ll definitely report back :wink:

(EDIT: I’m also getting crashes now, when using the Workspaces, so there’s definitely something going on)

(apologies… I was much more concerned about the crashes with Workspaces, than the specific issue with the non-updating Score Editor window :wink: )…
If anyone else is getting frequent crashes with Workspaces, I hope the following can help (short of rebuilding Cubase Preferences from scratch, of course)…
Even though I had saved a set of Workspaces with my Default Project, they were getting overwritten by the Global Workspaces, because I had “Auto Instantiate” enabled (and there was apparently something wrong with at least one of those Global Workspaces).
So, I de-activated that option, then removed all Global Workspaces, then replaced them with the current Project Workspaces.
… So far, so good (but still waiting for the next crash :smiling_imp: )
Sorry for the O.T., but maybe the info will be of use to someone :wink:

(Back on topic)… once I am more certain that these crashes are over, I’ll get back to testing with updating the Score Editor (although I’m already beginning to suspect that the behavior you are experiencing is “as designed”, in which case, this would be a Feature Request, rather than a bug report)

Some other undesirable behavious that I discovered today, whilst trying to find a workaround to the first problem, if you have the score editor open (in one workspace) and glue or cut a part, the score editor just closes by itself !

I can’t think of any good reason for that to be intentional on Steinberg’s part (although as tech support still haven’t replied, I can’t say for sure …)