Score editor shows muted notes

Is there an option anywhere which allows you to prevent the display of muted notes in the score? Or perhaps to display these in a different shade?

Setting the color of muted notes in the score, sure you can:
Go to File>Preferences, under Scores/Colors for Additional Meanings, you can change the color for muted notes. By default it’s grey.

But automatically hiding muted notes in the score, not that I know.

I see that you can change the colour of muted notes on the screen, but when printed they come out black again.

In this case disable the colors for muted notes in Preferences.
Then select your muted notes in the score (you can use Logical Editor for that), activate Event Colors in the score toolbar if it’s not already there, and use it to color your notes.
This way your colors will print out.