Scrambled background image in the Mixer


I noticed this issue in some situations. I’m using NotePerformer 3 with Dorico Pro 2. When opening the Mixer with an existing score, or a new one, the Mixer appears ‘scrambled’. Please see the attached picture.

Dorico is freshly installed, with no preferences from previous versions.


I suggest you alert Arne to this issue directly, as this looks to be a NotePerformer redraw issue of some kind.

Thank you Daniel, I’ll do.


It looks like an OpenGL driver issue. It’s hard to say what’s causing it. It could be another application, a faulty driver, running out of video memory. Does restarting Dorico help?

Arne, restarting Dorico didn’t work for a few times. Then it worked. I avoided restarting my Mac, to see if it was something that could be solved with restarting only the app.

I agree with you that it might be some ‘dirt’ in the video memory.


May I ask which version of OS X you’re running, for troubleshooting? I’ve seen some OpenGL problems on Mavericks, occasionally.

Either way, it’s not likely to be something that’s caused by Dorico. Partly because I don’t think they use OpengL (anyone correct me if I’m wrong) but also because, from the looks of your screenshot, your browser is writing stuff into what’s supposed to be our mixer’s background image. :slight_smile:

My best guess is that your video card ran out of video texture memory, and decided to release our background graphics and give that memory to your browser instead.

Arne, the OS I’m running is Sierra. I believe you are right about the low video memory, since the old Mac mini was notorious for how low its video memory was.


Sounds reasonable!

If you’re using e.g. Chrome, you may be able to turn off hardware acceleration and preserve video memory. Then again, as long as this isn’t happening consistently, you’re probably going to better off having a fast browser than having our background graphics. :slight_smile: