Screen jumps when editing parts

If I have a midi editor open in the lower zone and I glue or cut that part in the project window, often the view jumps ahead.

Quite annoying because I am focused on something and all of a sudden it’s out of view.

I can disable the “link project and lower zone editor cursors” between project and lower window and then the jumps don’t happen, but I want that link, I just don’t want the screen jumps…

Is there a solution to this?


This is because the old view closes and the new one opens (very often at the very beginning of the MIDI Part).

Yes, I understand, but it leads to very sudden and unpredictable quirks… at least for me. The view suddenly changes when all I did was cut or glued a part.


What I do when opening Key Editor and the view is not as I expect (around the cursor), I hit F key (Auto Scroll) 2 times. When the Auto Scroll is enabled, the view jumps to the cursor position automatically.

And the 2nd F hit is there just to get back to my original settings (Auto Scroll enabled or disabled).

thanks for the suggestion…

I think I have to get used to either reset the view or toggle “link project and lower zone editor cursors”…

YES!! This drives me nuts. Totally breaks concentration and have to zoom out to find where you’ve been moved to, then zoom back in again. Very frustrating! Another work around is to click the auto-scroll icon for it to move to your cursor like @Martin.Jirsak does with the F key. I didn’t know about that so I’ll have to try that now, but why have it move and require a workaround versus staying where it’s at, where you are working?