SD3 audition full

Hey guys im using superior drummer 3 however im muting the kick/snare/toms and only using it for the overheads & room. the kick (C1) & snare (D1) im sending to an audio track with slate trigger 2 on it which activates my own samples. same thing with toms.
heres the problem though: when I audition midi grooves inside SD3 it sounds gnarly because its only playing the Overheads and fatiguing the ear. How can I make it so that it plays the whole drums whenever I am auditioning grooves inside SD3? below is a snippet of the midi drum map im using which shows the routing per note.

Thanks in advance

I believe you have to un-mute the channels you said you muted. Did you mute those in the SD3 mixer?

if I unmute them then the whole mix ends up being wrecked since im only using SD3 for the overheads

You have to have MIDI Through turned on in Cubase preferences. An issue arises then. When you’re auditioning in SD3 you will hear all the SD3 sounds twice causing phasing. Either you live with that or you create a specific drum map without the SD3 sounds mapped for auditioning purposes only.

Hi midi thru is already ticket in my preferences.
Im not getting all the sounds (or double with phasing like you mentioned).

Your description of your setup and the issue is rather vague and the screenshots does not help much either. Therefor I made a few assumptions before posting.

  • You have a Drum Map where some drum sounds are routed to SD3 and some to other VST instruments
  • You have MIDI Out enabled in SD3

Are the above assumptions true?

hey

to understand it correctly, when you audition some midi grooves within SD3, you also want to hear your Slate Trigger Samples that you have routed from your drummap?

i dont think that will work nicely because you would end up with some midi loop feedback
but perhaps that could if you work with some temp midi tracks? you will need to give it a try

superior drummer 3 → midi out to - temp Drums midi track with your custom midimap that outputs certain notes to Trigger -set this track to monitor and once you hit play it should play trigger, but you have to mute all the SD3 notes on that track so that SD3 doesnt get them twice
however, when you then play your normal midi track, you need to ensure it doesnt send midi data again to that temp track… thinking about such already gives me headache, lol

i would rather keep the current setup and audition the midi grooves through cubase and not SD3 instead
or
instead of loading the samples in Slate Trigger, load them in SD3 directly
or
Load your Slate Trigger channels onto the audio output channels of your now muted SD3 tracks and let them trigger of from audio instead of midi?

or (well, this might work) :thinking:
audition midi grooves from a 2nd instance of SD3 that routes only the midi signal to your midi drum track with your custom drummap, but actual no audio, if this works out than you would get your main SD3 for overhead and room sounds and the trigger for the slate trigger sounds

Awesome thanks I made a video about it here incase anyone bumps into this in the future;