Sebastian Music Font with Narrow, sans serif font bug

If you choose the Sebastian music font in Dorico 5 and then select the narrow, sans serif option in: Layout Options - Time Signatures, the time signature disappears. If you go to Library, Font Styles, Time-signature font, and change it specifically to Bravura, the narrow, sans serif time signatures come back. I was using Sebastian in v.4.3 as my default music font and the narrow, sans serif font was fine, so something has changed from the Sebastian font that I had previously installed and the font that now ships with Dorico 5. Changing to Bravura of course fixes it.

1 Like

Paging @benwiggy to answer this in the first instance – I will look into it further if he has no explanation for you!

Hmm. I can confirm the behaviour, at least.

AFAICT, the only change has been to add the text font associations to the JSON file. A quick version comparison reveals no other differences between 1.08 and 1.07.

What version of Sebastian did you have before installing D5? Can you restore it (and the JSON file) from a backup?

Hmmm. This is a bit weird.

Sebastian does not have glyphs for Narrow Sans time sigs, and has never had them; so they must always have been substituted by Bravura.

Dorico 4 does display the time sig correctly, even when no substitute is listed in the Font Styles. However, Dorico 5 does not display anything, even when Bravura is explicitly listed as a substitute.

Paging @dspreadbury !

Yes, it is a bit strange…I was using Sebastian v. 1.07 for what it’s worth. It occurred to me that Dorico was probably always using Bravura because once I selected it, it looked exactly the same as what I thought had been the Sebastian font.
I have been preparing a number of scores using this big sans serif time signature so I was a bit taken aback when they disappeared in D5, but at least I know how to get them back again!

1 Like

I discovered a weird bug since updating that I think could be related.

I have the engraving option for tuplet numbers set to the ‘light’ appearance, but the music font I use (MTF Scorlatti) does not have symbols for that. Bravura is set as a substitute (and has been used as such in D4) but doesn’t seem to take any effect. The tuplet numbers just appear as square boxes.

It’s possible that the update caused a general problem with font style substitutions, maybe?

1 Like