Selecting audio event should display that event in editor

I can’t remember if this was ever the case - and I’ve got no other versions installed to check - but I feel that when I click on an audio event I should see that event immediately display in the lower pane.

I’ve had a look through Prefs and see that Editors > Editor Content Follows Event Selection is checked.

I’ve also noticed that when I have an audio event selected I can zoom upper and lower zones independently, whereas with a MIDI event selected the zoom levels are tied. In fact, with MIDI tracks it all seems to work as per Prefs, but with Audio it doesn’t and I can’t see a specifically audio setting to change this.

Something appears broken…