Selecting midi clip moves editor view to the start of the clip

Let’s say I’m working in the midi editor of track 1 (Guitar) on bar 57.
When I click track 2 (Bass) to edit the same bar the editor jumps to the beginning of the midi clip (bar 1) and I have to scroll back to bar 57.

Is there a way to change this behavior? It’s very time consuming if I’m moving between a lot of tracks.

Check to see if you have “Track Selection Follows Event Selection” checked in your editing prefs. If so, uncheck and see if you still are seeing this behavior.

1 Like

It doesn’t really solve the issue. I would still like to use track selection to navigate between midi clips.

Although for some reason without “Track Selection Follows Event Selection” opening midi clips in an editor does follow the playhead and doesn’t force the editor to the beginning of the clip.

I think this is just how it works. it’s been a topic of discussion regularly over the years. My workaround is to hit select all, then zoom to selection. You can make a macro of those two commands and bind to a keystroke.

1 Like

Yeah, it’s a shame. Thanks for the help

If you have your project cursor around where you are editing, you could make use of Auto Scrolling.
I typically have Auto Scrolling turned off, activate it using the default key command F which brings the cursor position into view and then hit F again to deactivate Auto Scrolling.

1 Like

hmm, using a hotkey to switch to auto-scroll and back to re-center the view is not a bad idea. I’ll check it out.

Actually that’s better!