Selecting midi clips jumps to start in key editor

This was a recorded issue in Cubase 7/7.5, I’ve just upgraded to Cubase 8 hoping this would have been solved but it still happens.

In brief:

Open key editor for a midi clip
Set locator somewhere other than the start of the project
Leave key editor open and select another clip in the mix window
Key editor will jump to the start of that clip instead of where the locator currently is

Is there a new setting in 8 that will stop this happening? When writing long orchestral cues this is a real pain because I have to either double tap keypad-enter or spacebar to relocate the key editor. When going through 30+ instrumental parts it becomes quickly infuriating!

Yes, I can confirm this.

I will just correct your reproduction which is not clear in some points:

  • Add two MIDI tracks.
  • On every single MIDI track, create a MIDI part. Every MIDI part will start on different position.
  • Open the KeyEditor of one of the MIDI part.
  • Set the Cursor (playback head) to different position, than
  • Leave the KeyEditor open, and select the second MIDI part in the Project window.
    => KeyEditor view jumps to the beginning of the currently select MIDI part, not to the position of cursor.

The workoround, I’m using is: pres “F” key twice onyour computer keyboard, in the KeyEditor, to disable, and enable Auto-Scroll. Thanks to this, the KeyEditor view jumps to the Cursor position.

Thanks Martin for clarifying the steps to reproduce this.

Yep double tapping F works but it’s not at all convenient.

Can we have some comment from the devs as to when/if this will ever be looked at?

Please forgive the bump but I would like to know what the next course of action would be to try and get this issue addressed…

Yes, I’d like this one fixed too please Steinberg!

Also, it’s worse in the event editor because it doesn’t scroll vertically when you press the F key twice, only horizontally. The only way to make it scroll vertically is to rewind back and then go forward a bit. I use a macro for this.