Selecting notes

I originally appended this material to another thread. That was a few minutes ago. Then I deleted it from that thread and started a new thread: this one.

For speed and simplicity, I like to start by entering everything as 16th notes, then consolidate those into 1/8ths, 1/4’s, etc. using Shift-Option-RightArrow. This almost works except that I have not found a way to select just notes I want without switching to the mouse every time. I’ll try to illustrate this in case my meaning is not clear.

What I start with:

What I end up with:

What I want:

In the first screenshot, one note is selected. Good. Next I want to select just the other note(s) in the same voice, without having to use the mouse. The second screen shot shows that I can only select every note, not just the one I want. I want to do this so I can use Shift-Option-Arrow to increase, for example, a 1/16th note to an 1/8th note.
If I can find a way to do this, I can sail through a lot of input really fast! I do a lot of this, so I would like that.

Do have another go at uploading those screenshots.

Try this. Did it work?

Try typing Tab. You may find the Write > Edit Duration > Extend to Next Note function useful, particularly if you assign a key command to it (and note that you can apply it to a passage).

I’m trying to get all the notes on the stem to light up so they all work together when I extend the duration. It seems I must use the mouse for that unless there’s another way.

Wait! I found it! Shift-Cmd-A does it.You got me looking in the right place. Thank you.

But from your initial selection, does the Tab key not achieve the same result?

1 Like

When I tried Tab, the notes lit up left to right. I was looking for the notes to light up vertically, so to speak. I want all the notes on the stem to change together when I use Shift-Option-Arrow.
When I would do that and go on to the next note, only one note on the stem would light up. Then I would have to click the mouse to light up the other note(s) on the stem. Now I find that Shift-Option-A does that. Problem solved.
The screenshots show the sequence. I hope you are able to see them. They show on my screen.

That’s decidedly odd. I find that if I start with your initial selection - one of the two notes in the chord - Tab selects that note and the other note in the same chord (in the same voice). Anyway, I’m glad you’re sorted.

I am as surprised as you are because now I agree with you. Oh well.
If I see it happen again I’ll try to make it repeatable and share it.
Since this problem is solved (!) and if see the behavior again, should I append to this thread or start a new one?

Well, it does different things at different times. I’m sure there’s an algorithm, but it’s too hard for my brain to deal with. But there is a foolproof solution: Write/Edit/Select More (Shift-Cmd-A), done exactly one time, lights up all the right notes every time. I’m going with that.

Yes, that will select the whole chord which is great.