Selecting of notes is not behaving as expected.

I have a glissando that was imported via a MIDI file. I want to select all notes except the first, then I’ll add a glissando mark. I’m drawing a box around the notes that I want to select (see first screenshot), but no matter what, Dorico also selects the first note—which I’m NOT selecting.

How do I get Dorico to respect my selections?

If there’s no way to do so, I’d have to classify this, respectfully, as a bug. :slight_smile:
2 - What gets selected.png

OK. Speaking of bugs, there are bugs in this forum software: I keep attaching two images—and both show up in the preview—but when I submit my post, one image gets omitted. Frustrating.

Here’s the omitted image, showing the selection box I was drawing:
1 - Drawing a selection box.png

The reason the first note is getting selected is because you are also selecting the beam: when you click on the beam, all of the notes in the beamed group are selected, which is a nice shortcut (another nice shortcut is clicking on the stem to select all the noteheads on the stem).

I’d say the best workflow to achieve what you want is :

  1. Click on the beam
  2. Cmd-click the first note to deselect it
  3. Cmd-click the next beam (The two last notes) to add it to the selection


  1. Marquee select as you did
  2. Cmd-click the first note to deselect

The first workflow avoids the marquee selection which can be a good thing if its behavior displeases you.

Good to know. Thanks!

I’d like to request that perhaps Shift-Marquee or Option-Marquee be added to ignore the stem and select only the notes that fall within the selection. Thanks again.

Great tips. Thanks!