Serious bug in Spectralayers 11.0.10

Ok, today I came in a very difficult situation in front of my clients in the studio.
Trying to use “unmix song” in a vocal track to separate the vocal from the acoustic piano bleed, in the unmixed audio appeared two lines of “noise” at 11 khz and 15 khz (see screenshots). I used the high quality setting.
I uninstalled immediatelly v11 and I installed version 10, and everything became to normal.
Unacceptable behavior from a professional paid program.
Steinberg never let me feel a “beta-tester” the last 30 years that I’m using their products.


…Have you looked at your Amplitude setting top right ? You’re looking at a line that appears when setting the display at -150dB !
So it’s very likely that you could not hear it at all, AND that it was cancelled by the Other layer anyway (the sum of all layers is always equal to the original file).
Unless you have proof that it caused audible distortion, this really looks like a non-issue to me, rather some band transition, you should better stay with v11 if you want the best separation quality :slight_smile:

2 Likes

“The Best separation quality” sounds nice to my ears and this is the reason that I upgraded to v11. The reason that I started this topic is because these high frequencies are hearable. I posted the screenshots as a proof of what I hear and as I mentioned, this happened during my work with my clients that brought me in a difficult situation. So instead of being ironic with my hearing, you should take a look in the software, instead if you are doing software for children. Anyway, if this can help you, I can send you samples of the original and the processed audio, on bothe version 10 and 11 to listen by yourself.

The screenshot itself doesn’t show much given that amplitude was set at - 150dB : at that level, any microscopic frequency bump is visible.
Yes please, upload an audio sample (of the original file before unmixing).

Also, please remain courteous : your first post was quite aggressive right away, and your second is pretty aggressive too. I read this forum everyday, several times a day to help users and fix issues as soon as they are reported, but it’s much easier to do so with users who are really looking for help and not being unpleasant right from the beginning. Please understand that it’s the first time the issue you’re reporting has ever been mentioned here, it’s not like I was aware of such issue and did nothing about it for months!

13 Likes

I apologize for the aggressive tone on my previous post, it was because you doubt my finding.
I’m a person who targets the sound and not a graphs maniac.
But we all have the right to be civilized so, excuse me one more time again.
Keep in mind that I love Spectralayers from day one when became a Steinberg product and it is an important tool for the daily works in my studio.
Here is 1) the original audio (voice+piano) and 2) the piano stem.
I used the high quality setting to separate these two elements. I’ve also attached a screenshot of the piano stem in Wavelab.


The problematic freqs which appeared after the unmix process are hearable and noticable.
The subject is that this problematic behavior doesn’t exist on Spectralayers 10

2 Likes

I can see the horizontal lines you’re referring to after unmixing in SL11, but I really have to boost the spectrogram amplitude to see it…
And TBH, when I select them specifically and audition them I can’t hear anything given their very low amplitude (unless that’s my headphones, or my aging ears ?) :

That being said, 2 things:
-I think I know where this is coming from, that might be fixable for patch 2.
-Meanwhile you can still switch back to SL11, because it really provides better vocal extraction on your audio sample (much less vocal bleeding into Piano/Other), and if you really want to avoid the new algorithm at all cost you can just set Unmix Song to “Fast” quality and you’ll get something quite similar to SL10, without the horizontal lines.

Or even better, you can have the best of both world by unmixing your song 2 times (make a duplicate of your original layer) : unmix it with Fast, and unmix it with Extreme. Then just copy the higher frequency range (10KHz-22Khz) from the Fast unmixing to the Extreme unmixing :slight_smile:

3 Likes

It’s true, that after unmixing I don’t hear these frequency lines.
For some reason I hear them only on the separated stems at each one.
Thank you very much for your suggestions and for the tips!

1 Like