serious peak overloads.

i bought cubase 7 in december, was charged for a 7.5 upgrade, and to add insult to injury it has never worked right.
i just cant stand the peak overloads and all i really want to know is why? what is causing them. i know this is my first post, but ive been a lurker for a very long time. i never really posted because it seems that there is no real answer. it seems, cubase works or it doesn’t.

why has steinberg dropped the ball so hard on version 7 and what is being done to fix it. and why wont steinberg even respond to anybody on why they cant fix it, and how, did they screw up so badly in the first place?

i just really need some help here because i really am getting stressed lately with the peak overloads.

no one will be able to give you support if you don´t mention your specs, sound card, latency settings etc.
Rambling about your “bad luck” won´t take you far. I can already tell you the reasons: User Error, bad setup, or both

So you bought in December, what do you mean by “charged for a 7.5 upgrade”, didn´t you read the info on the Cubase product page:

"All customers who have activated Cubase 7 or Cubase Artist 7 (includes full retail version, educational version, updates and upgrades) on October 15, 2013, or later, are eligible to obtain a free Grace Period update to Cubase 7.5 or Cubase Artist 7.5. "



my specs,

intel q9450 quadcore 2.6 ghz, 3 gigs of ram, windows764
m-audio delta 2496, 512 latency.

well no, i bought it in december of 2012.

When exactly do the peak overloads occur?

I reckon your system is clean, no unnecessary crap running in the background processes?
Tried increasing buffer size and different latency settings?
Tried Asio guard on/off?
Tried CPU hyper threading on/off?
Some wonky virus checker active?
Running Cubase 64 bit version with some old 32bit plugins?

Lots of possible causes for a phantom problem…

yeah, well that´s clearly out of the Grace Period :wink:

well, i do have avast, comodo firewall, running, and i often have multiple firefox tabs open (i just checked, i have 14 tabs open including this one)

It might not at all be related to your problem but DAWs and virus checkers sometimes don´t do well together. Any reason you are not using the Windows built in tools? Windows Firewall and Microsoft Security Essentials do the same job and are well integrated. No need for third party software from my experience.

ok, ill give it a shot. also i notice my memory usage was 50 percent, but my closing all my tabs it went down to 32.

Some more RAM would be worthwhile too.


but why is turning off asio guard recommended on some pcs and not on others? also, the same for turning on/off multicore, and i have my audio priority set to normal, disk preload on 2 seconds, and i removed comodo.

well, i was planing to buy a new pc in march. an i5 or i7. with 4-8 gigs of ram.

the spikes are a known problem but only for specific systems.
the steinberg moderators are answering the posts and looking for solutions but they can’t be on every topic.
this is still under investigation as far as i know because there was no final solution for it found yet

in the search window on top of this forum enter “asio spikes” and you will find 1.000+ topics
maybe some of them correspond to your system settings
as far as the problem is resolved it is related to changing the graphic drivers.
so this is system related.

Others spike issues still remain and are related to some specific plugins like for the moment play 4 from EWQL and reaktor also has some of the ensembles as problematic.
but also there, by far the most seem related to the graphic drivers interfering with the audio drivers.

It is a such not cubase related because other DAW’s also suffer from the same issue.
but the forum can be a good starting point.
very clear layout of your system specs and correct communication is essential for these kind of problems if you want them to look into it.

but i also agree that your ram is also quite low for a 64 bit system
but that won’t solve the spikes if i’m right

kind regards,

so do i switch to 32 bit cubase? uncheck all the asio guard checks, and turnoff asio guard and maybe multicore? at this point there’s nothing i can do about my system so all i can do is software tweaks/fixes. i did switch my driver to amd catalyst 12.10

whats the most common solution to fix the peaks? and please, could somebody answer my question about asio guard and multicore? i do have a creative another graphics card i could try, a geforce 9500gs 512 mb im currently using an ati 4850 1gig

i didn’t mention that

swithing to the 32 bit DAW version could benifit you if you are using only 32 bit plugins on a 64 bit system
bridging 32 bit plugins to a 64 bit daw only takes power away and gives no benefit
the system has to recalculate everything from 32 to 64

but if you use 64 bit plugs, you will not be able to use them on a 32 bit system and also there is a memory limit for 32 Bit systems.

But if so, and you only use 32 bit plugins, yes… there is no benefit on the usage of a 64 Bit daw (unless you use specific plugin hosts within the daw)

though this 32/64 discussion seems not related to the spike issue.
there are posts with spikes with 32 bit daws also

also a good idea is to check the basic references on daw setup on the steinberg site

kind regards,