Serious problem with Cub Audio Engine / multicore (PC only, null tested)

Dear Cubase users and development team,

There seems to be an issue with the audio engine: When you turn on the [ multiprocessing engine button ] the sound seems to degrade and become less ‘three-dimensional’ and more flat / muffled / dull. This seems to be further degrading as you turn on ASIO GUARD.

Problem: Turning on [ multiprocessing engine ] button makes the sound lose clarity, three-dimensionality and ‘punch’. This isn’t VERY obvious but it’s still audible and I would somewhere between 10 -15% of quality loss. (( please confirm, PC only ))

I have spent days and days (actually weeks) listening and comparing and have done several null-tests.

The null tests indicate: This issue doesn’t seem to arise with just exporting wavefiles without insert effects. Then the waves are identical and null out.

The problems starts when using insert effects and the way these tracks and effects interact with eachother. Of course I tried to avoid any modulation effects as I tested.

From my personal perspective I would suspect there is something wrong with the ‘frequency separation engine’ (especially when track counts increase).
I just like the sound better when everything is off: (multiprocessing and ASIO Guard) however it’s not possible to work that way in terms of processor performance. So basically I want to work on a single core but then I would have to buy a new PC etc with a very fast single processor. Kinda annoying.

Due to the above issues I have a lot more difficulty achieving a pro sound compared to working in Studio One, Bitwig or Ableton. I think it is time for a complete overhaul and improvement of the audio engine. I do love the Cubase features and workflow. I think it’s the best but this is an issue I keep running into.

Please investigate and improve the Audio Engine and the way that performance features (like multi processing and Asio Guard) impair sonic quality. There are several other posts by others about exactly this subject (as far back as 2016!) but due to the renewed forum I couldn’t directly find them.

I would appreciate it if PC users could try and verify that turning off multiprocessing (Studio Setup) improves sound quality for about 10-15% (It’s subtle but noticable).
Please listen for Clarity, Punch, Stereo Image etc.

I want to make clear that I do love Cubase and it’s creative workflow. I am just sharing a very serious concern that I have run into and have thoroughly tested.

Due to the above issues I have compared Cubase and for example Studio One for the last year - intensely and thoroughly - with exactly the same instruments and plugins and fader settings and every single time the sound of Studio One sounded more open, more spacious and punchier.

I am not looking for a general discussion about whether this is even possible but after testing for over a year I can definately say there is something to it. Even my mixing clients and students confirmed this.

Win 10 Pro build 19043.1237
Intel(R) Core™ i5-4670 CPU @ 3.40GHz 3.39 GHz
16,0 GB

If you would post wav or aiff files showing the 10% to 15% change in the output it can be confirmed.