Serum 64bit Blacklisted, wtf is this shit?

Hi,

Can someone please explain how i can get xfer serum working in cubase 9.5? Purchased genuine version and its blacklisted, even though its 64bit. I tried movindg the .dll into cubase 9,5 folder and that still doesnt work. Also tried to reactivate it in plugin manager and that just freezes cubase then it crashes

Hi,

Most probably the plug-in failed during the Cubase testing, so it was blacklisted. It seems, there is a bug in the plug-in.

Make sure you have the very latest update of the plug-in installed. If yes, get in touch with the vendor, please.

Hmm. Great

Problem is likely with your install, try reinstall Serum.
Have the latest version here (1.214) and use it in pretty much every project without any problems.

Tried thrice, same issue

Is your version vst3?

The one I got off splice is vst2

Splice version here too, vst2

Where is yours installed? Is it a funky path?
Keep my vsts in e:\vstplugins (for 64bit) and both SerumFX and Synth load fine.

There’s a xfer folder in c:\users$username$\appdata\roaming that has some configs for serum in, try delete that as well as reinstall.

Had the splice version for well over a year now though and never any issues in Cubase.
Maybe contact xfer support?

Thanks. Has installed cleanly on my desktop, but still playing up on laptop, can’t get it off the blacklist. Weird!

Got it working now. Nice synth too