Set up external instrument problem

I am seriously confused about how to set up my Kawai acoustic/electric piano as an external instrument track.

The manual says -

"Connecting an External Instrument/Effect
The hardware device has stereo inputs and outputs.

  1. Connect an unused output pair on your audio hardware to the input pair on your external hardware device.
  2. Connect an unused input pair on your audio hardware to the output pair on your hardware device.
    If you select input/output ports for external instruments/effects that are already used, the existing port assignment breaks without warning."

Does that mean I need to run audio cables back into the piano? Why? Surely the point is that the piano is being played back via MIDI to generate the audio that goes out in the usual way.

I have watched endless videos that attempt to explain how to set this up properly but I’d be grateful if someone could point me in the direction of a good explanation of the complete process I need to follow.



Brian, those instructions are covering instruments AND outboard effects. Effects would require an input, of course, but your piano doesn’t. So yes, just send the signal from the piano to the interface.

Ah yes, of course, that makes sense - thank you. But I’m still having trouble setting this up anyway. I’ll have yet another go tomorrow and if I still can’t manage it I’ll try and home in on the specific problem and post again with more detail.


You didn’t supply any system specs or the model of your piano/keyboard and what kind of connections it has.

So assuming you are running Cubase on a PC and your keyboad has a midi to usb connection this very general procedure might help. Check it out. I hope it helps.

  1. With the Computer started, CB not started, keyboard off… Connect the midi to usb cable to the proper connections on your piano/keyboard and computer.
    Hopefully you will hear windows recognize the device (keyboard) when you plug it in.
  2. Start CB
  3. Open a project or start a new project that has an “Instrument Track” (or midi track but use an Instrument Track for this try). Add the Instrument Track if you don’t already have one. Also make sure the project has a Stereo input/output channel(track).
  4. Highlight the instrument track and press the track number near the top left of the inspector to see the input routing (which should drop down and be visible when you press that track number button). Select “All MIDI Inputs”.
  5. Just below that choose the vst instrument you want to use. Choose Halion Sonic SE for this setup and choose any instrument (but choose GM 006 Electric Piano for this try). Don’t forget to activate the effect by pressing the button in the upper left of Halion. It needs to be blue colored.
  6. Turn on your keyboard
  7. Now the tricky part. The piano/keyboard has to be set to send just the midi signal to your computer and not send the tone signal generated from your keyboard. To do that your manual will have instructions to follow. Basically you are turning “off” the tone signal generated from your piano/keyboard.
  8. Now press a keyboard key. Hopefully it is working and you can hear a delightful electric piano.

Again, I have assumed a bit here as you really did not supply much detail. So if it doesn’t work, supply some more info and maybe we can assist further.

Regards :sunglasses:


Thanks for your reply. My specific problem is in setting up what Cubase calls an “instrument track” with my external acoustic/electric piano. I’m OK with using this as a master keyboard triggering internal sounds in Cubase, I can record MIDI from the keyboard and I can record audio from the piano.

What I can’t do is to set up the piano as an external instrument such that I can create a combined MIDI/audio track as the instructions suggest should be possible. It may not be worthwhile wasting more time trying to do this as I can work in other ways - but I would like to understand what is going on here.

This is what happens:-

In VST connections I add an external instrument - 1 stereo return, name - KAWAI, associate MIDI device - KAWAI again (no other option)

Return bus 1 L& R not connected - switch to Mic/Instrument in 7 & 8 get message “The selected device is already used. Selecting the port will replace any previous connection.” (Well that’s a pain 'cos it messes up routing from the electric drum kit (that’s another story) - but go ahead anyway.)

So, go to my project - Add track - Instrument track - External plug-ins - KAWAI - add track. Track appears in project OK and I can record on it and see and hear the notes going in, MIDI notes nicely laid out in the editor.

BUT - I can hear nothing on playback. And this morning that is where I’m stuck.

Grateful if you can offer any suggestions. The Piano is a Kawai “Anytime” acoustic/electric hybrid which doesn’t appear in the Cubase list as a suggested external instrument so I had to define it as a new instrument. Interface is a MOTU 8pre although MIDI is being handled by a Roland UM 1. All running on an Apple Mac computer.

Thank you


When you open the MIDI device manager, is there a midi output assigned in the little black window at the bottom?

Thank you - I would love to answer your question but at the moment I am struggling to understand why my system is silent because it fails to remember my routing in VST connections.

I am getting nowhere fast.

If I press F4 should the vst connections window not pop up? All that happens for me is that Cubase whizzes off the screen to the right and I get the clock, calculator and an indication of the temperature in London.

I want my 8 track tape machine back.

That’s not Cubase. I don’t know what system you’re on, but that’s handled in the keyboard preferences of the computer.

I’m sure you are right - never had to look in to that before. Now the metronome is completely silent and yes I do have version 8.0.20 and it is turned on.

First make sure that the KAWAI is receiving MIDI on playback. Your description implies that it doesn’t. Then the problem presumably resides with the MIDI output assignment in Cubase or the MIDI input settings on the KAWAI.

The fact that you hear the KAWAI while recording is a completely different matter. In order to use the KAWAI as an external audio module (which is for all intents and purposes what you are doing) you need to break the connection between the keyboard and the audio engine of the KAWAI. Otherwise the KAWAI will receive double playback instructions for each note you play. On from the keyboard and another from the MIDI input. This will use up two voices per note, essentially halving the KAWAIs polyphony count. The latency of the MIDI “copy”, caused by the Cubase round-trip, will also result in phasing effects. You may also suffer stuck notes, since the MIDI protocol doesn’t allow for dual note-on messages. The fist note-on should be followed by a note-off, before a new note-on is sent for the same note.

This is fixed by a setting called “Local Off”, or something similar, on the KAWAI.


  1. Check that the KAWAI is receiving MIDI on playback.
  2. If it does, check the MIDI settings in Cubase (including Philskeys suggestion) and on the KAWAI.
  3. Make sure that the KAWAI is set to “Local Off”.

Are you turning off the track “monitor” function when trying to hear the track during playback?

An “instrument” track in Cubase is used to record midi signals from a midi generator (in your case, the keyboard) and play that back using the vst instrument sound(s) loaded on your computer. As far as I know you cannot use a Cubase instrument track to create a combined midi/audio track. I looked at the Kawai Anytime manual and I guess what is on page 7 is what you are referring to. That example is hooking the output jacks of your keyboard to an amp with speakers and listening to the digital sound through those speakers while, at the same time hearing the acoustic sound of your piano. That is not that same as connecting midi through a computer to be processed by Cubase.

The only way I can think that might work with Cubase is if you can record your midi to a Cubase instrument track and, at the same time, place a mic near your piano and record the acoustic sound to a Cubase audio track. The op manual does not specifically address this so I’m not sure if your keyboard will do it.

I believe you said that you have figured out how to record midi using your keyboard and playback sounds using CB. So you must have figured out the “local off” procedure. If that is correct, then if your piano can make acoustic sounds while doing that then, just place a mic near it and record that, at the same time, to an audio track.

Btw… That’s an interesting keyboard with the capability to play acoustic piano sounds and/or a few digital sounds at the same time. Cool! :wink:

Regards. :sunglasses:

To Svenne

“This is fixed by a setting called “Local Off”, or something similar, on the KAWAI.”

Thanks - this is not the problem - I am familiar with the concept of “Local off” - and that is the setting I am using. I have been experimenting more and will explain the problem hopefully more clearly in a further message below.

Thanks for the reply. I think we have a bit of a misunderstanding here - and apologies for not being more clear in my original questions.

As I understand Cubase Pro 8 (not much yet) - it should be possible in the vst connections window to set up the piano as an external instrument that can be played via an “instrument track” as if it were an internal vsti. I can get so far with setting this up but a problem arises with the vst input routing. Stereo output from the piano goes to inputs 7 & 8 of my MOTU 8pre interface. Now there is another output bus going to 7 & 8 which handles stereo cymbals from my electronic drum kit; I use a simple real switch in the cabling to record drums or piano at any one time.

OK - BUT when trying to set up routing for the instrument track I am trying to create it will override this setting.

So in simple terms - how to route the audio if I want to set up an "instrument track?’

In reality it’s not hugely important - I can record the digital output of the piano (and associated sounds), I can record the MIDI output and route it where I want and I can use the piano as a master keyboard for computer based sounds. I just get stuck on this “set up external instrument” business - and that irritates me 'cos I do like to try and understand what is or is not happening with the routing of things. It was a lot simpler when we used cables.

And yes - it is a fantastic keyboard to play - acoustic when I want and silent when I don’t. I have tried recording the acoustic sound with microphones but unless I spend a lot of money getting better mics and a better room to put it in the results don’t justify the effort. Only downside as a master keyboard is no mod or pitch wheel but I use a M-Audio oxygen8 when I need that.


I found it to be a little tricky. I suggest going back and following the steps exactly as in the manual.(external instruments) Make sure that the output is assigned in the midi device manager. That seems to disconnect itself on me, but cubase gives a reminder when that happens.
It does work, and while not necessary, it is handy feature.

I got the same issue! Please make sure if you are hooking your Keyboard synth as external instrument. You press f4 and make sure output is routed to correct outputs. Also, Put your keyboard as MIDI Controller. In my Yamaha PSR case, I need to put all the local controls to off!