setting up midi keyboard transport controls with cubase

H, I just need advice on how to setup my controllers play/stop/re record/record buttons on my new midi keys to cubase. tired midi learn etc but nothing happens.

pc windows 10 64bit, midi keyboard is a new M audio oxygen61 usb, cubase is 8.5 pro full.

the keys, pitch bend/mod and pads all work out the box, but theres play/stop record buttons that dont do anything when pressed and I would like to get them working. any advice much appreciated, cant find much on youtube or m audio’s site. thanks


Use Generic Remote Device, from Devices menu, please.

Once you get to the Remote Device Setup screen and you add Generic Controller…from there it is not easy or clear. Spent hours fiddling with it and changing the parameters. A lot of guides online assume you know all the rest. Any help would be appreciated.


What exactly do you want to achieve?

I’d like to get my modulation wheel and transport buttons working on my M-Audio Keystation 61 with Cubase, Halion Sonic (the steinberg products at least).


Modulation wheel should work straight. It just sends MIDI CC1, which is in sue by HALion Sonic by default.

What exactly should the Transport button do in HALion Sonic, please? Btw, for controlling plug-ins, you have to use something different than the Generic Remote Device. We are using the Generic Remote Device for internal Cubase functions only.


I have an M-Audio Keystation 61 MK3…and a Akai MPK mini…neither of their mod wheels (or stick) work to control Halion Sonic’s mod wheel.

And the transport buttons are just to Start, Stop and Record in cubase.

(And I’m not concerned with any other plugins right now…if the mod wheel works with Halion sonic…I’ll be happy).

Windows 10 (64bit)
Cubase 11 Elements

Have you checked, that you’re not inadvertently filtering MIDI CC 1 (mod wheel) in your Preferences settings?

for example in my settings I’m filtering CC 123 and everything on Channel 16 and all System Exclusive messages:


Apart from the MIDI Channel 16 filter, this is the default settings.

@Martin.Jirsak yes, exactly - but just around a couple of weeks ago, this midi filter preference ended up being the problem for somebody else here whom I was able to help, who had messed with those settings, forgot about it, and was subsequently mystified why some midi messages from external devices were ignored by Cubase. – So this is one possible explanation for none of the mod wheels working and thus worthwhile checking.


I know, it’s quite common. Good hint in any case.

Hello Martin…thanks for the reply.

I have never been to that setup screen…so it’s untouched.

Is there anything else I can check?

Here is another setup screen…just in case.


Do you use any Generic Remote Device with the MIDI Device, now?

Additional things to check:

  • Use the Midi Insert called Midi Monitor so ensure that the modwheel (and any other desired messages from your midi controller are arriving at the track.

  • If the Midi Monitor is showing the flow of midi messages arriving at the track, next check the midi filter settings in Halion Sonic and ensure, you are NOT filtering controller messages there. :

  • If the Midi Monitor is NOT showing the flow of midi messages, check if you have assigned your midi controller to one or both Quick Controls or in any of the various Mackie Control devices in the settings or found under the menu Studio > Studio Setup . – Ensure your midi controller is NOT connected to any of those.

  • If all of the above doesn’t help, check if your midi controller is even sending controller messages with a separate utility program like MIDI-OX

“Do you use any Generic Remote Device with the MIDI Device, now?”

Yes, I do.


Remove them, os set the MIDI Input to Not Connected, please.