settings key commands gone after closing dorico

First of all: compliments and gratulations to the new update! I am enthusiastic about the brilliant cue functions and fingerings. You did not only invent the wheel anew, but gave it a new and never thought of gear mechanism.

I have got only a little problem, since I run Dorico 1.2: I assigned some personal settings for keycommands, esp. for Note Durations. I assigned them again after installing 1.2, because they were missing. Now they are missing after every closing of Dorico. How can I get the application to memorize my settings?
Settings in other parts of Dorico are memorized as should be.

A little help from any Dorico friend would be appreciated!

Margret

Sadly, I’ve had the same problem. I simply started over and went to the default setting and re-entered my key commands. Since then, my key commands have been stable. I figured it was something strange to do with my system, but now Margret, I know I am not alone.

Thanks for the quick answer, Kevin. Unfortunately the resetting of the key commands did not help.
But I will try further.

I dived deep into the AppDate/Roaming/Steinberg/Dorico keycommands_de.json file.
It looks as if some of my newly set keykommands will load when starting Dorico, others not.
All “DELETE” commands behave correctly; the old keycommands are gone.

Some of the key commands work fine:
e.g. “NoteInput.SetAccidental?Type=kSharp” : [ “#”, “DELETE:?” ]
or “NoteInput.SetArticulation?Value=kTenuto” : [ “Num±”, “DELETE:#” ]
or “NoteInput.NoteValue?LogDuration=kCrotchet” : [ “4”, “DELETE:6” ]

But others are gone, when starting Dorico:
e.g. “NoteInput.NoteValue?LogDuration=kQuaver” : [ “8”, “DELETE:5” ]
or “NoteInput.NoteValue?LogDuration=kSemibreve” : [ “1”, “DELETE:8” ]
“NoteInput.NoteValue?LogDuration=kMinim” : [ “2”, “DELETE:7” ]
“NoteInput.NoteValue?LogDuration=kSemiQuaver” : [ “6”, “DELETE:4” ]

I don’t quite understand what is different between these two groops.
And I don’t know how to tell Dorico to save my keyboard shortcuts not only in the *.json file but to load them when starting.

I am using a Cherry keyboard with german keyboard layout.

It would be very nice if anybody could help!
Margret

I have the same problem (Noteinput value), on Mac with german keyboard.

I have a similar experience. Some personal key commands disappear after closing Dorico. I did some tests, and it’s always the same keys that disappear: @ (which is Shift+2 on my keyboard), and # (which is Shift+3 on my keyboard). I experience no problem with the key commands ! (Shift+1) and $ (Shift+4).

Regards,

Stefaan

For now I have the following solution (or rather workaround):
all personal key commands which are lost after restarting Dorico have been replaced by me in the following way:
instead of 8 -> Alt+8
instead of 1 -> Alt+1
instead of 2 -> Alt+2
instead of 6 -> Alt+6.

These key commands work fine d.h. they reappear after starting Dorico.
It seems as if, using the german keyboard layout, some key commands will not load properly.
I think, it is a little bug; surely it will be fixed some day.
Till then we have to test which keys are working and search for an acceptable alternative.

Regards to all of you
Margret

I’m also having key command bindings disappear, for commands similar to those described by others in this group. For example

3 -> set Note Duration to 1/4 note
4 -> set Note Duration to 1/8 note

and the like. They disappear after I restart the program. Resetting all key commands didn’t help, and re-entering them several successive sessions never made them “stick”.

This is unfortunate as I had hoped to switch to Dorico with 1.2, but now have to retreat back to Sibelius. I hope this is fixed soon!

We will look into this, and if there’s a problem, we will make sure it gets fixed as soon as possible.

I’m struggling with the same thing on macOS Sierra. Dorico maintains all other key commands after a quit/restart, except for those that are replacing a default Dorico shortcut. My JSON file shows the replacement key commands, but they do not show up in the key commands dialogue box, and are inactive.

I only use two non-standard shortcuts (MacOS High Sierra): 1 and 2, for adjusting the rhythmic grid. These have always worked for me, in every Dorico update.

There is a bug here that revolves around changing the default key command for a command that has parameters, such as the note duration commands. It will be fixed in the next update. In the meantime I’m sorry for the inconvenience caused.

Thanks for the note Daniel. Is this likely to be a maintenance update in the near future, rather than the Giant No Longer 1.X Update presaged in release notes?

Yes, it’s likely that we will release a small update in January to fix this and a few other things.

same problem here…all keycommands are gone.
i copy-pasted an older keycommand file from a back-up into the Dorico 3.5 content folder: nothing…all shortscuts are still gone…

That’s the factory content folder - the application package itself. You should be replacing the keycommands file in the user folder (~Library/Application Support/Steinberg/Dorico 3.5), not this one.

I did that, too Leo - before I posted this…thanx…but you know what?
I took the backup file out of an older content folder and copied it to the Application Support folder. Great !
Stupid me.
Now I took the back up out of the Application Support folder, too…and everything works fine…wonder wonder :joy:

Thanx again