SHIFT Key no longer selecting


I am trying to select a two stave piano passage. I used to do this using SHIFT to first select the second stave, and then to select the end bar. Now the SHIFT key no longer works. Can you tell me what I am doing wrong?

Are you in Write mode? This doesn’t work the same way in Engrave mode - I think you have to draw a box (marquee selection?) around multiple items.

Hi - thanks for replying.

I am in write mode. It used to work, but now when I select the staff below and press SHIFT to select it, nothing happens. Likewise when I press SHIFT to select the end bar. The only thing different I have done is use chord symbols for the first time . . . But I have tried restarting Dorico, and it still no longer works for me.

I’ve noticed there’s sometimes a problem selecting white space between items (the staff itself) and items on the staff (like notes).
For me, it always works if I select a note at the start of the selection, and shift click a note (or rest) at the other end of the selection.
I don’t know whether this is at all helpful to you…

I am able to select to the end bar on one staff the way you suggested - so thank-you! - but selecting two staves is still not working. It used to work perfectly . . .

You ought to be able to select the first note in the top staff and the last note in the bottom staff and find that both staffs are selected in full - that’s what I get here.
Does it work if you select the first note, shift select the first note in the other staff, and then go Edit > Select to end of flow?

No, I’m afraid it doesn’t.

I guess in that case probably best to zip up the file and upload it here, or email it directly to Daniel to take a look. Sounds very odd to me.

It would certainly be interesting to know whether this problem also occurs in a newly-created project, or whether it seems to be isolated to the project you’re currently working on, in which case, yes, please zip it up and attach it here so I can take a look at it.

similar problem here in the song i’m working on
clickSelect a bar
hold shift
click in white white space
the range doesnt get selected
if I select the first note in a bar
hold shift
click last note of the last bar
the range gets selected


in the same song some measures allow click/shift selection (as described) some dont
if I copy paste the problem is pasted also

I’ll try to search for more clues…


PS: this was certainly working in 1.0.30 and seem to be related to the presence of chord symbols

chord in first selected bar inhibits the shift+click selection
or differently said
multiple bar selection by clicking in white space is not working when first selected bar contains a chord symbol
shift (340 KB)

In the forthcoming minor update, block selection (which is what we call selecting by clicking in a blank bit of the staff) will no longer select chord symbols, in common with other system-attached items like tempos and rehearsal marks, so these problems will go away.

Is this related to the fact I can’t click on the blank space in a bar to effectively highlight the entire bar and then apply a dynamic hairpin? Right now it doesn’t work. I can only apply a hairpin if I select a note and shift click another, or I lasso a selection. Annoying really.

Michael, under what circumstances do you find that you can’t select a whole bar? If there are chord symbols on that staff, that could explain it.

I´m having this problem as well, with v3.5:
trying to select all notes in a bar, either from the last or first noe, shift select does not select the notes between the two points, I need to repeat the process two or more times for making it work.