Shortcut or macro for locators to cycle

Can anyone suggest a way to set locators to cycle without touching the mouse?

You can set it as a Key Command (I don’t think the KC I’ve set it to in this pic is the default - so ignore that part).

I don’t think I really understand the question. What do you mean by “locators to cycle”? Are you referring to cycle markers?

locators to cycle markers

If yes, read this:
https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/playback/playback_setting_locator_ranges_c.html

Without touching the mouse… I don’t believe so. (From within Cubase without external tools that is)

The first solution that springs to mind is:

  1. Use keycommand to set left locator.
  2. Use keycommand to set right locator.
  3. Use keycommand to activate cycle.

If Cubase could wait between the key commands of a macro, it would be possible.

Thanks for the replies. In previous versions (don’t know when it changed) there was a option in the key strokes dialogue “Markers To Cycle”, I can choose a KS go to cycle 1, etc. and then choose left marker to curser, but the right marker doesn’t move, not as elegant as the old option, just saying. Once again thanks for the replies

We call this dialogue Key Commands window, not “key strokes dialogue”.

“Cycle 1”, “KS”?
Are you referring to cycle markers?
Usually KS stands for Key Switch, not Key Stroke.

“Left marker”? Hmmm…
Maybe “left locator”?


It’s still unclear what you’re asking. For other users (including me) is very important that you specify what the topic is about. Here, on the forum, we’re not solving only personal problems. We make sure that the discussions are easy to understand by any visitor.

Ok, I think I understood.

What @comsax1 is probably asking about, and please correct me if I’m wrong, is a key command to set locators to cycle marker.

In this case, you need Key command> Transport > Recall Cycle Marker 1-X.

Edit: For some reason, I see that I have assignments for these commands. They are Shift+ Num1-9. However, my keyboard won’t accept this combination. Rather what happens is, only the Num1-9 gets through, and then the cursor goes to the start of the cycle marker, as if I was giving a “To Marker 1-9” command. Maybe this is the cause of confusion? I’m on Windows by the way, maybe on mac it works fine?

Can anyone confirm if this assignment is default? Does it work for you people?

https://steinberg.help/cubase_pro/v11/en/cubase_nuendo/topics/key_commands/key_commands_dialog_r.html

1 Like