Shortcuts for Split Beam and Beam Together not working

Hi,

Dorico Pro 3.5.10 on Mac.

I assigned the shortcut Alt+: to Split Beam, and Alt+Shift+: to Beam Together.

They didn’t work. I saw that they were put in the kGlobal context in the preference file, and moved them to the kWrite context. I was careful to put the comma where needed, and remove it at the end of the list.

Still, the new shortcuts are not working. They don’t overlap with other commands.

Paolo

P.S: I noticed that Dorico is still creating a “Dorico 3” folder inside the Application Support/Steinberg/ folder. It stores the backup files there.

What physical keyboard layout are you using, what language are you using Dorico in, and what language is set in the dropdown at the top right corner of Dorico Preferences > Key Commands?

You can edit your preferences.xml file in a text editor to change the default AutoSave location to be inside the “Dorico 3.5” folder instead of “Dorico 3”. (Dorico should do this itself automatically, but Dorico 3.5 had a small bug that prevented this from happening; this is fixed in Dorico 3.5.10, but only for people who first update from a previous version of Dorico to Dorico 3.5 by running 3.5.10 first, not 3.5.0.)

Thank you for your answer, Pianoleo. I’m using a custom keyboard layout similar to the old ISO Italian. Dorico is in the English version, and the shortcuts are saved in the “keycommands_en.json” file. Dorico is assuming it is the “Default” keyboard language in the Key Commands pane.

I first created my keyboard shortcuts by directly typing them in the dedicated box in Key Commands. There should be an immediate match between what was typed there and what Dorico is receiving when using the shortcut.

The main character without modifier keys (:slight_smile: is correctly recognized, and the corresponding command is correctly received. Adding the modifier keys seems to break something in this case.

Paolo

Thank you very much, Daniel. This worked fine.

Paolo

The thing that’s puzzling me is I’m struggling to find a keyboard layout where : doesn’t need a modifier key to access it in the first place (typically Shift). What happens when you type that key into a word processor, for instance, and what happens when you type Alt-: or Alt-Shift-: into a word processor? For that matter, what is the Dorico Preferences > Key Commands displaying when you type those keys?

There are various shortcuts made of a single keypress. By default, I’m thinking to ‘Q’ for chords. Note names should also be available as single keypresses by default (sorry if I don’t remember correctly, but I’m using a lot of custom shortcuts).

In this particular case, the single-press ‘:’ is used to recall the Tuplet popover. These are the results of typing the alternative combinations in any text editor:

Alt-: - |
Alt-Shift-: - \

In the Key Commands pane, I don’t see the resulting character, but the symbol(s) for the modifier keys, and the ‘:’ character.

One double: the ‘’ character is reserved under Windows. Maybe this is causing troubles? But this wouldn’t explain why ‘|’ wouldn’t work as well.

Paolo

I don’t think you’ve quite understood. : is Shift-; on English keyboards and Shift-. on pretty much every Italian keyboard layout I can find. Is that not the case on your keyboard?

As far as I’m aware, \ is the English Mac shortcut for a tenuto articulation and | is the English Mac shortcut for a staccato+tenuto articulation. Do Shift-: and Shift-Alt-: give those articulations for you?

No, my layout is a custom one. Barely inspired to the original QZERTY layout used in the Olivetti typewriters, and then modernized and used by Apple until year 2000, it makes accessing characters common to the Italian language easier.

In my layout, the ‘:’ character is in the first position, since it is used very often (while the ‘;’ is now slipping into obsolescence; at least so I believe…).

Paolo

I reassigned the commands to different shortcuts, and they work fine. It’s probably something to do with some reserved character in the XML preference file.

Paolo