Show rests in 2nd voice before it enters

Showing and hiding of rests in Dorico is really winding me up! I’ve asked this before, but in response to another question so it might have got lost. How do I show rests in a second voice before that voice enters? I have Bar rests in additional voices: Show bar rests selected, but because there’s nothing in the second voice yet, there’s nothing I can set “starts voice” on, so how can I get Dorico to show rests in that voice? Please? Before my frustration drives me back to the competition…

  1. Put in the first couple notes of second voice, so there’s something in that voice.
  2. Staying in note input mode, use Ctrl-left arrow to move caret back to previous measure, the empty one before 2nd voice starts.
  3. With 2nd voice still active, Shift-B, “rest” (without the quotes"), hit Enter.
  4. Rinse and repeat as needed

Step 1 is necessary because there has to be something in voice 2 before you can create bar rests for it. I found this out by trial and error.

However long you waited to post on the forum, sounds like it was too long… :wink:

Thanks so much for that tip Dan - it was bugging me too; mainly for SATB on two staves.
Awesome!
David

one thing i’ve noticed is that if you use “remove rest”, and then enter some music in that voice (additional voice, show bar rest in additional voice mode), and then subsequently remove that music, you don’t get the rest back; in fact, I can’t figure out how to get that default behaviour back. If you forgot you used “remove rest”, the behavior would seem bewildering to a new user.

You go to the note before the removed rest and untick the “ends voice” property, or you go to the note after the removed rest(s) and untick the “starts voice” property.

All of this would be solved by having a permanent numbered voice system like “the competition”. Just imho, but I, too, have had many frustrations with inputting multiple voices and it seems like an unnecessary failure of such a semantics-based app.

Thanks. works except in the first measure. something strange until the measure the second voice enters

dankreider’s 3rd step should fix this: if you want a bar rest in the bar(s) before the second voice starts, set the caret to the start of the bar, use V to toggle to the correct voice, type Shift+B, type rest into the popover and Enter.

@pianoleo. Thanks for taking the time to illustrate that.
If you now enter music in the lower voice of the first measure and remove it, your other trick of finding the start-voice box in the next measure doesn’t work… you must use this technique you illustrated. It’s this inconsistancy I was referencing.

thanks again.